diff mbox series

[bug#49025,v4,core-updates,16/36] openssl: Remove trailing #t from phases.

Message ID 20210619150458.12057-17-maximedevos@telenet.be
State Accepted
Headers show
Series Support cross-compilation with meson | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

M June 19, 2021, 3:04 p.m. UTC
* gnu/packages/tls.scm
  (openssl)[arguments]<#:phases>: Delete trailing #t.
---
 gnu/packages/tls.scm | 12 ++++--------
 1 file changed, 4 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 31ffdb2a8a..3688449efe 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -363,8 +363,7 @@  required structures.")
                            ((string-prefix? "powerpc64" target)
                             "linux-ppc64")
                            ((string-prefix? "powerpc" target)
-                            "linux-ppc")))
-                 #t)))
+                            "linux-ppc"))))))
            '())
         (replace 'configure
           (lambda* (#:key outputs #:allow-other-keys)
@@ -403,8 +402,7 @@  required structures.")
               (for-each (lambda (file)
                           (install-file file slib)
                           (delete-file file))
-                        (find-files lib "\\.a$"))
-              #t)))
+                        (find-files lib "\\.a$")))))
         (add-after 'install 'move-extra-documentation
           (lambda* (#:key outputs #:allow-other-keys)
                ;; Move man3 pages and full HTML documentation to "doc".
@@ -417,8 +415,7 @@  required structures.")
                  (copy-recursively man3 man-target)
                  (delete-file-recursively man3)
                  (copy-recursively html html-target)
-                 (delete-file-recursively html)
-                 #t)))
+                 (delete-file-recursively html))))
         (add-after
          'install 'remove-miscellany
          (lambda* (#:key outputs #:allow-other-keys)
@@ -427,8 +424,7 @@  required structures.")
            (let ((out (assoc-ref outputs "out")))
              (delete-file-recursively (string-append out "/share/openssl-"
                                                      ,(package-version this-package)
-                                                     "/misc"))
-             #t))))))
+                                                     "/misc"))))))))
    (native-search-paths
     (list (search-path-specification
            (variable "SSL_CERT_DIR")