diff mbox series

[bug#49025,v3,core-updates,13/37] wrap-python3: Make #:builder a G-exp instead of a raw S-exp.

Message ID 20210618171631.20534-13-maximedevos@telenet.be
State Accepted
Headers show
Series [bug#49025,v3,core-updates,01/37] utils: Define target-linux? predicate. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

M June 18, 2021, 5:16 p.m. UTC
This allows using ungexp later.

* gnu/packages/python.scm (wrap-python3)<#:builder>: Make this
  a G-expression.
---
 gnu/packages/python.scm | 46 ++++++++++++++++++++---------------------
 1 file changed, 23 insertions(+), 23 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b2ec486d7a..9628836567 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -573,29 +573,29 @@  for more information.")))
     (arguments
      `(#:modules ((guix build utils))
        #:builder
-         (begin
-           (use-modules (guix build utils))
-           (let ((bin (string-append (assoc-ref %outputs "out") "/bin"))
-                 (python (string-append (assoc-ref %build-inputs "python") "/bin/")))
-                (mkdir-p bin)
-                (for-each
-                  (lambda (old new)
-                    (symlink (string-append python old)
-                             (string-append bin "/" new)))
-                  `("python3" ,"pydoc3" ,"idle3" ,"pip3")
-                  `("python"  ,"pydoc"  ,"idle"  ,"pip"))
-                ;; python-config outputs search paths based upon its location,
-                ;; use a bash wrapper to avoid changing its outputs.
-                (let ((bash (string-append (assoc-ref %build-inputs "bash")
-                                           "/bin/bash"))
-                      (old  (string-append python "python3-config"))
-                      (new  (string-append bin "/python-config")))
-                  (with-output-to-file new
-                    (lambda ()
-                      (format #t "#!~a~%" bash)
-                      (format #t "exec \"~a\" \"$@\"~%" old)
-                      (chmod new #o755)
-                      #t)))))))
+       ,#~(begin
+            (use-modules (guix build utils))
+            (let ((bin (string-append (assoc-ref %outputs "out") "/bin"))
+                  (python (string-append (assoc-ref %build-inputs "python") "/bin/")))
+              (mkdir-p bin)
+              (for-each
+               (lambda (old new)
+                 (symlink (string-append python old)
+                          (string-append bin "/" new)))
+               `("python3" ,"pydoc3" ,"idle3" ,"pip3")
+               `("python"  ,"pydoc"  ,"idle"  ,"pip"))
+              ;; python-config outputs search paths based upon its location,
+              ;; use a bash wrapper to avoid changing its outputs.
+              (let ((bash (string-append (assoc-ref %build-inputs "bash")
+                                         "/bin/bash"))
+                    (old  (string-append python "python3-config"))
+                    (new  (string-append bin "/python-config")))
+                (with-output-to-file new
+                  (lambda ()
+                    (format #t "#!~a~%" bash)
+                    (format #t "exec \"~a\" \"$@\"~%" old)
+                    (chmod new #o755)
+                    #t)))))))
     (synopsis "Wrapper for the Python 3 commands")
     (description
      "This package provides wrappers for the commands of Python@tie{}3.x such