diff mbox series

[bug#49025,[PATCH,v2,core-updates] 20/37] openssl: Move all man pages to separate output, not only man3.

Message ID 20210618160936.18972-20-maximedevos@telenet.be
State Accepted
Headers show
Series [bug#49025,[PATCH,v2,core-updates] 20/37] openssl: Move all man pages to separate output, not only man3. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

M June 18, 2021, 4:09 p.m. UTC
There does not seem to be any reason to only move man3 pages.
So, move all man pages to a separate output for documentation.

* gnu/packages/tls.scm
  (openssl)[arguments]<#:phases>{move-extra-documentation}: Move
  all man pages, not only man3.
---
 gnu/packages/tls.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 9aa0b5a212..c178806805 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -411,16 +411,16 @@  required structures.")
                         (find-files lib "\\.a$")))))
         (add-after 'install 'move-extra-documentation
           (lambda _
-               ;; Move man3 pages and full HTML documentation to "doc".
+               ;; Move man pages and full HTML documentation to "doc".
                (let* ((out    #$output)
-                      (man3   (string-append out "/share/man/man3"))
-                      (html (string-append out "/share/doc/openssl"))
+                      (man    (string-append out "/share/man"))
+                      (html   (string-append out "/share/doc/openssl"))
                       (doc    #$output:doc)
-                      (man-target (string-append doc "/share/man/man3"))
+                      (man-target (string-append doc "/share/man"))
                       (html-target (string-append doc "/share/doc/openssl")))
-                 (mkdir-p (dirname man3-target))
+                 (mkdir-p (dirname man-target))
                  (mkdir-p (dirname html-target))
-                 (rename-file man3 man-target)
+                 (rename-file man man-target)
                  (rename-file html html-target))))
         (add-after
          'install 'remove-miscellany