diff mbox series

[bug#49025,[PATCH,v2,core-updates] 18/37] openssl: Use G-exp machinery for referring to outputs.

Message ID 20210618160936.18972-18-maximedevos@telenet.be
State Accepted
Headers show
Series [bug#49025,[PATCH,v2,core-updates] 18/37] openssl: Use G-exp machinery for referring to outputs. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

M June 18, 2021, 4:09 p.m. UTC
This doesn't fix anything broken, just for simplifying
the code a little while we're rebuilding the world anyway.
IMHO this makes the code a little more readable.

* gnu/packages/tls.scm (openssl)[arguments]<#:phases>: Don't refer
  to the association list 'outputs', use #$output, #$output:doc
  and #$output:static instead.
---
 gnu/packages/tls.scm | 28 ++++++++++++++--------------
 1 file changed, 14 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 9de9a78e84..90211c733d 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -16,6 +16,7 @@ 
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -347,7 +348,7 @@  required structures.")
        #$@(if (%current-target-system)
           #~((add-before
                'configure 'set-cross-compile
-               (lambda* (#:key target outputs #:allow-other-keys)
+               (lambda* (#:key target #:allow-other-keys)
                  (setenv "CROSS_COMPILE" (string-append target "-"))
                  (setenv "CONFIGURE_TARGET_ARCH"
                          (cond
@@ -371,8 +372,8 @@  required structures.")
                             "linux-ppc"))))))
              #~())
         (replace 'configure
-          (lambda* (#:key outputs #:allow-other-keys)
-            (let* ((out (assoc-ref outputs "out"))
+          (lambda _
+            (let* ((out #$output)
                    (lib (string-append out "/lib")))
               ;; It's not a shebang so patch-source-shebangs misses it.
               (substitute* "config"
@@ -398,23 +399,23 @@  required structures.")
                              #~((getenv "CONFIGURE_TARGET_ARCH"))
                              #~())))))
         (add-after 'install 'move-static-libraries
-          (lambda* (#:key outputs #:allow-other-keys)
+          (lambda _
             ;; Move static libraries to the "static" output.
-            (let* ((out    (assoc-ref outputs "out"))
+            (let* ((out    #$output)
                    (lib    (string-append out "/lib"))
-                   (static (assoc-ref outputs "static"))
+                   (static #$output:static)
                    (slib   (string-append static "/lib")))
               (for-each (lambda (file)
                           (install-file file slib)
                           (delete-file file))
                         (find-files lib "\\.a$")))))
         (add-after 'install 'move-extra-documentation
-          (lambda* (#:key outputs #:allow-other-keys)
+          (lambda _
                ;; Move man3 pages and full HTML documentation to "doc".
-               (let* ((out    (assoc-ref outputs "out"))
+               (let* ((out    #$output)
                       (man3   (string-append out "/share/man/man3"))
                       (html (string-append out "/share/doc/openssl"))
-                      (doc    (assoc-ref outputs "doc"))
+                      (doc    #$output:doc)
                       (man-target (string-append doc "/share/man/man3"))
                       (html-target (string-append doc "/share/doc/openssl")))
                  (copy-recursively man3 man-target)
@@ -423,13 +424,12 @@  required structures.")
                  (delete-file-recursively html))))
         (add-after
          'install 'remove-miscellany
-         (lambda* (#:key outputs #:allow-other-keys)
+         (lambda _
            ;; The 'misc' directory contains random undocumented shell and Perl
            ;; scripts.  Remove them to avoid retaining a reference on Perl.
-           (let ((out (assoc-ref outputs "out")))
-             (delete-file-recursively (string-append out "/share/openssl-"
-                                                     #$(package-version this-package)
-                                                     "/misc"))))))))
+           (delete-file-recursively (string-append #$output "/share/openssl-"
+                                                   #$(package-version this-package)
+                                                   "/misc")))))))
    (native-search-paths
     (list (search-path-specification
            (variable "SSL_CERT_DIR")