diff mbox series

[bug#49025,[PATCH,v2,core-updates] 10/37] libgpgerror: Maybe fix a cross-compilation bug.

Message ID 20210618160936.18972-10-maximedevos@telenet.be
State Accepted
Headers show
Series [bug#49025,[PATCH,v2,core-updates] 10/37] libgpgerror: Maybe fix a cross-compilation bug. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

M June 18, 2021, 4:09 p.m. UTC
Previously, a symlink was created at
src/syscfg/lock-obj-pub.linux-gnu.h pointing at
lock-obj-pub.MANGLED-TARGET.h. I would think this has
to be the other way around, but I am not really sure.

* gnu/packages/gnupg.scm
  (gnupg)[arguments]<#:phases>{cross-symlinks}(link): Switch
  'triplet' and 'source'.
---
 gnu/packages/gnupg.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index de213d381f..f5d4118af9 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -110,9 +110,9 @@ 
              (add-after 'unpack 'cross-symlinks
                (lambda _
                  (define (link triplet source)
-                   (symlink (string-append "lock-obj-pub." triplet ".h")
+                   (symlink (string-append "lock-obj-pub." source ".h")
                             (string-append "src/syscfg/lock-obj-pub."
-                                           source ".h")))
+                                           triplet ".h")))
                  ,(let* ((target (%current-target-system))
                          (architecture
                           (string-take target (string-index target #\-))))