diff mbox series

[bug#49047,2/3] gnu: xdg-desktop-portal: Update to 1.8.1.

Message ID 20210615165327.491-3-andrew@trop.in
State Accepted
Headers show
Series Update pipewire and xdg-desktop-portal[-wlr] | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Andrew Tropin June 15, 2021, 4:53 p.m. UTC
* gnu/packages/freedesktop.scm (xdg-desktop-portal): Update to 1.8.1.

Make xdg-desktop-portal aware of portal implementations via
XDG_DESKTOP_PORTAL_DIR variable.
---
 gnu/packages/freedesktop.scm | 20 ++++++++++++++++++--
 1 file changed, 18 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index e4ea951c41..14775cf743 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2269,7 +2269,7 @@  fallback to generic Systray support if none of those are available.")
 (define-public xdg-desktop-portal
   (package
     (name "xdg-desktop-portal")
-    (version "1.7.2")
+    (version "1.8.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -2278,7 +2278,7 @@  fallback to generic Systray support if none of those are available.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0rkwpsmbn3d3spkzc2zsd50l2r8pp4la390zcpsawaav8w7ql7xm"))))
+                "0pq0kmvzk56my396vh97pzw4wizwmlmzvv2kr2xv047x3044mr5n"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -2298,6 +2298,22 @@  fallback to generic Systray support if none of those are available.")
        ("geoclue" ,geoclue)
        ("pipewire" ,pipewire-0.3)
        ("fuse" ,fuse)))
+    (arguments
+     `(#:phases
+       (modify-phases
+        %standard-phases
+        (add-after 'unpack 'po-chmod
+                   (lambda _
+                     ;; Make sure 'msgmerge' can modify the PO files.
+                     (for-each (lambda (po)
+                                 (chmod po #o666))
+                               (find-files "po" "\\.po$"))
+                     #t)))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "XDG_DESKTOP_PORTAL_DIR")
+            (separator #f)
+            (files '("share/xdg-desktop-portal/portals")))))
     (home-page "https://github.com/flatpak/xdg-desktop-portal")
     (synopsis "Desktop integration portal for sandboxed apps")
     (description