diff mbox series

[bug#49022,1/2] gnu: inkscape: Update to version 1.1.

Message ID 20210614132744.23856-1-boris.dekshteyn@gmail.com
State Accepted
Headers show
Series [bug#49022,1/2] gnu: inkscape: Update to version 1.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Boris A. Dekshteyn June 14, 2021, 1:27 p.m. UTC
* gnu/packages/patches/inkscape-1.1-fix-build-witch-gcc7.5.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/inkscape.scm (inkscape-1.0) Rename to inkscape-1.1.
* gnu/packages/inkscape.scm (inkscape-1.1) Update to version 1.1.
---
 gnu/local.mk                                  |  1 +
 gnu/packages/inkscape.scm                     |  9 +++----
 .../inkscape-1.1-fix-build-witch-gcc7.5.patch | 24 +++++++++++++++++++
 3 files changed, 30 insertions(+), 4 deletions(-)
 create mode 100644 gnu/packages/patches/inkscape-1.1-fix-build-witch-gcc7.5.patch

Comments

Nicolas Goaziou June 18, 2021, 11:21 a.m. UTC | #1
Hello,

"Boris A. Dekshteyn" <boris.dekshteyn@gmail.com> writes:

> * gnu/packages/patches/inkscape-1.1-fix-build-witch-gcc7.5.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
> * gnu/packages/inkscape.scm (inkscape-1.0) Rename to inkscape-1.1.
> * gnu/packages/inkscape.scm (inkscape-1.1) Update to version 1.1.

Applied both patches. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index fdbf2272ed..b1c5bebfa8 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1241,6 +1241,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch	\
   %D%/packages/patches/inetutils-hurd.patch			\
   %D%/packages/patches/inkscape-poppler-0.76.patch		\
+  %D%/packages/patches/inkscape-1.1-fix-build-witch-gcc7.5.patch	\
   %D%/packages/patches/intel-xed-fix-nondeterminism.patch	\
   %D%/packages/patches/intltool-perl-compatibility.patch	\
   %D%/packages/patches/iputils-libcap-compat.patch		\
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index 075f901b2d..46c8c4cc34 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -117,19 +117,20 @@  apart is its use of Scalable Vector Graphics (SVG), an XML-based W3C standard,
 as the native format.")
     (license license:gpl2+)))
 
-(define-public inkscape-1.0
+(define-public inkscape-1.1
   (package
     (name "inkscape")
-    (version "1.0.2")
+    (version "1.1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://media.inkscape.org/dl/"
                            "resources/file/"
                            "inkscape-" version ".tar.xz"))
+       (patches (search-patches "inkscape-1.1-fix-build-witch-gcc7.5.patch"))
        (sha256
         (base32
-         "12krl97a00gdcxxibsb7g2lgx5458mhx2437x0hvz350242j6gns"))
+         "1rlm2wqg8bgdxkdvnadh49wfp0mrbrk7d8n4vdcjyw6z7z7firki"))
        (modules '((guix build utils)
                   (ice-9 format)))
        (snippet
@@ -188,7 +189,7 @@  endif()~%~%"
                          (string-append "#include " quote
                                         (basename source-dir)))
                         ...))))))
-             (unbundle ("2geom" "src/2geom" #t)
+             (unbundle ("2geom" "src/3rdparty/2geom" #t)
                        ;; libcroco cannot be unbundled as it is heavily
                        ;; modified (see:
                        ;; https://gitlab.com/inkscape/inkscape/issues/876#note_276114904).
diff --git a/gnu/packages/patches/inkscape-1.1-fix-build-witch-gcc7.5.patch b/gnu/packages/patches/inkscape-1.1-fix-build-witch-gcc7.5.patch
new file mode 100644
index 0000000000..bd7b01f856
--- /dev/null
+++ b/gnu/packages/patches/inkscape-1.1-fix-build-witch-gcc7.5.patch
@@ -0,0 +1,24 @@ 
+From 0ae15d7e89b984f72780ff7afa8e57dd6ae7765a Mon Sep 17 00:00:00 2001
+From: "Boris A. Dekshteyn" <boris.dekshteyn@gmail.com>
+Date: Mon, 14 Jun 2021 23:52:16 +1200
+Subject: [PATCH] Fix build witch GCC@7.5.
+
+---
+ src/object/sp-use-reference.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/object/sp-use-reference.h b/src/object/sp-use-reference.h
+index 5958632059..f07c2a3721 100644
+--- a/src/object/sp-use-reference.h
++++ b/src/object/sp-use-reference.h
+@@ -14,6 +14,7 @@
+ 
+ #include "sp-item.h"
+ #include "uri-references.h"
++#include "display/curve.h"
+ 
+ #include <memory>
+ 
+-- 
+2.32.0
+