diff mbox series

[bug#48989] gnu: Add ddcui.

Message ID 20210612221606.16297-1-brice@waegenei.re
State Accepted
Headers show
Series [bug#48989] gnu: Add ddcui. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Brice Waegeneire June 12, 2021, 10:16 p.m. UTC
* gnu/packages/hardware.scm (ddcui): New variable.
---
 gnu/packages/hardware.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Mathieu Othacehe June 18, 2021, 12:29 p.m. UTC | #1
Hello Brice,

> * gnu/packages/hardware.scm (ddcui): New variable.

Building this package fails with the following error on my machine:

--8<---------------cut here---------------start------------->8---
CMake Error at CMakeLists.txt:45 (find_package):
  By not providing "FindQt5.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Qt5", but
  CMake did not find one.

  Could not find a package configuration file provided by "Qt5" with any of
  the following names:

    Qt5Config.cmake
    qt5-config.cmake

  Add the installation prefix of "Qt5" to CMAKE_PREFIX_PATH or set "Qt5_DIR"
  to a directory containing one of the above files.  If "Qt5" provides a
  separate development package or SDK, be sure it has been installed.


-- Configuring incomplete, errors occurred!
See also "/tmp/guix-build-ddcui-0.1.2.drv-0/build/CMakeFiles/CMakeOutput.log".
command "cmake" "../source" "-DCMAKE_BUILD_TYPE=RelWithDebInfo" "-DCMAKE_INSTALL_PREFIX=/gnu/store/jfrs3l9lwyaznml9kqzcnpy64gabyad9-ddcui-0.1.2" "-DCMAKE_INSTALL_LIBDIR=lib" "-DCMAKE_INSTALL_RPATH_USE_LINK_PATH=TRUE" "-DCMAKE_INSTALL_RPATH=/gnu/store/jfrs3l9lwyaznml9kqzcnpy64gabya1
builder for `/gnu/store/i4raw95kpbvdarj48f1iirq0yk0m35gr-ddcui-0.1.2.drv' failed with exit code 1
build of /gnu/store/i4raw95kpbvdarj48f1iirq0yk0m35gr-ddcui-0.1.2.drv failed
View build log at '/var/log/guix/drvs/i4/raw95kpbvdarj48f1iirq0yk0m35gr-ddcui-0.1.2.drv.bz2'.
guix build: error: build of `/gnu/store/i4raw95kpbvdarj48f1iirq0yk0m35gr-ddcui-0.1.2.drv' failed
--8<---------------cut here---------------end--------------->8---

Any idea why?

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index ecbcca79b1..54370c928e 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -43,11 +43,13 @@ 
   #:use-module (gnu packages polkit)
   #:use-module (gnu packages protobuf)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages web)
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg)
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -100,6 +102,36 @@  calibrated, and restored when the calibration is applied.")
     (license (list license:bsd-3        ; FindDDCUtil.cmake
                    license:gpl2+))))    ; everything else
 
+(define-public ddcui
+  (package
+    (name "ddcui")
+    (version "0.1.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/rockowitz/ddcui")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0myma1zw6dlygv3xbin662d91zcnwss10syf12q2fppkrd8qdgqf"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f))                    ; No test suite
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("qttools" ,qttools)))
+    (inputs
+     `(("ddcutil" ,ddcutil)
+       ("glib" ,glib)
+       ("qtbase" ,qtbase)))
+    (home-page "https://www.ddcutil.com/")
+    (synopsis "Graphical user interface for ddcutil")
+    (description "ddcui is a graphical user interface for ddcutil, implemented
+using Qt.  It provide a dynamic way to inspect and configure external monitors
+through the Display Data Channel Command Interface (@dfn{DDC/CI}) protocol.")
+    (license (list license:gpl2+))))
+
 (define-public edid-decode
   (let ((commit "74b64180d67bb009d8d9ea1b6f18ad41aaa16396") ; 2020-04-22
         (revision "1"))