diff mbox series

[bug#48982] gnu: brightnessctl: Add elogind support.

Message ID 20210612212410.13185-1-brice@waegenei.re
State Accepted
Headers show
Series [bug#48982] gnu: brightnessctl: Add elogind support. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Brice Waegeneire June 12, 2021, 9:24 p.m. UTC
* gnu/packages/patches/brightnessctl-elogind-support.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/linux.scm (brightnessctl)[source]: Apply it.
[make-flags]: Enable logind support.
[native-inputs]: Add pkg-config.
[inputs]: Add elogind.
---
 gnu/local.mk                                        |  1 +
 gnu/packages/linux.scm                              | 13 +++++++++----
 .../patches/brightnessctl-elogind-support.patch     | 13 +++++++++++++
 3 files changed, 23 insertions(+), 4 deletions(-)
 create mode 100644 gnu/packages/patches/brightnessctl-elogind-support.patch

Comments

Ludovic Courtès June 16, 2021, 8:58 p.m. UTC | #1
Brice Waegeneire <brice@waegenei.re> skribis:

> * gnu/packages/patches/brightnessctl-elogind-support.patch: New patch.
> * gnu/local.mk (dist_patch_DATA): Register it.
> * gnu/packages/linux.scm (brightnessctl)[source]: Apply it.
> [make-flags]: Enable logind support.
> [native-inputs]: Add pkg-config.
> [inputs]: Add elogind.

LGTM, thanks!

Ludo'.
Brice Waegeneire June 17, 2021, 6:22 a.m. UTC | #2
Pushed as 375d5d03c91e722c1fcf17d456c303c53b0b5a80.
Dhruvin Gandhi June 26, 2021, 3:45 p.m. UTC | #3
This patch no longer installs the udev rules it used to install.
I think the description should be updated as well. Mentioning how to use
brightnessctl.
Brice Waegeneire June 26, 2021, 5:14 p.m. UTC | #4
Hello Dhruvin,

Dhruvin Gandhi <contact@dhruvin.dev> writes:

> This patch no longer installs the udev rules it used to install.
> I think the description should be updated as well. Mentioning how to use
> brightnessctl.

Thank you for the report, looks like I didn't took enought care when
submiting the patch.  It is fixed in
5a13e950b2bd0860ee91bcd61a2a3c1a1ec0f616 by readding udev rules to the
package.

Cheers,
- Brice.
Dhruvin Gandhi June 27, 2021, 7:22 a.m. UTC | #5
Hello Brice

Brice Waegeneire <brice@waegenei.re> writes:

> Hello Dhruvin,
>
> Dhruvin Gandhi <contact@dhruvin.dev> writes:
>
>> This patch no longer installs the udev rules it used to install.
>> I think the description should be updated as well. Mentioning how to use
>> brightnessctl.
>
> Thank you for the report, looks like I didn't took enought care when
> submiting the patch.  It is fixed in
> 5a13e950b2bd0860ee91bcd61a2a3c1a1ec0f616 by readding udev rules to the
> package.
>
> Cheers,
> - Brice.

I have reconfigured my system with latest commit and brightnessctl works
as expected. Thank you for your prompt response to this issue and for
the commit that fixed it.
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 73556cc184..26b3e86e22 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -851,6 +851,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/bazaar-CVE-2017-14176.patch		\
   %D%/packages/patches/bc-fix-cross-compilation.patch		\
   %D%/packages/patches/bear-disable-preinstall-tests.patch	\
+  %D%/packages/patches/brightnessctl-elogind-support.patch	\
   %D%/packages/patches/bsdiff-CVE-2014-9862.patch		\
   %D%/packages/patches/bsd-games-2.17-64bit.patch		\
   %D%/packages/patches/bsd-games-add-configure-config.patch	\
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2b0c32666c..c8917f1830 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -36,14 +36,13 @@ 
 ;;; Copyright © 2019, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2019 Stefan Stefanović <stefanx2ovic@gmail.com>
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
-;;; Copyright © 2019, 2020 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2019, 2020, 2021 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2020 Chris Marusich <cmmarusich@gmail.com>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
-;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
@@ -6413,13 +6412,15 @@  set the screen to be pitch black at a value of 0 (or higher).
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0immxc7almmpg80n3bdn834p3nrrz7bspl2syhb04s3lawa5y2lq"))))
+                "0immxc7almmpg80n3bdn834p3nrrz7bspl2syhb04s3lawa5y2lq"))
+              (patches (search-patches "brightnessctl-elogind-support.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no tests
        #:make-flags (list (string-append "CC=" ,(cc-for-target))
                           (string-append "PREFIX=" %output)
-                          (string-append "UDEVDIR=" %output "/lib/udev/rules.d/"))
+                          (string-append "UDEVDIR=" %output "/lib/udev/rules.d/")
+                          "ENABLE_SYSTEMD=1")
        #:phases
        (modify-phases %standard-phases
          (delete 'configure)
@@ -6428,6 +6429,10 @@  set the screen to be pitch black at a value of 0 (or higher).
              (substitute* "90-brightnessctl.rules"
                (("/bin/") "/run/current-system/profile/bin/"))
              #t)))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("elogind" ,elogind)))
     (synopsis "Backlight and LED brightness control")
     (description
      "This program allows you read and control device brightness.  Devices
diff --git a/gnu/packages/patches/brightnessctl-elogind-support.patch b/gnu/packages/patches/brightnessctl-elogind-support.patch
new file mode 100644
index 0000000000..8125f1c459
--- /dev/null
+++ b/gnu/packages/patches/brightnessctl-elogind-support.patch
@@ -0,0 +1,13 @@ 
+From https://github.com/Hummer12007/brightnessctl/issues/67
+
+--- a/Makefile
++++ b/Makefile
+@@ -18,6 +18,8 @@ MODE = ${MODE_${INSTALL_UDEV_RULES}}
+ ifdef ENABLE_SYSTEMD
+ 	CFLAGS += ${shell pkg-config --cflags libsystemd}
+ 	LDLIBS += ${shell pkg-config --libs libsystemd}
++	CFLAGS += ${shell pkg-config --cflags libelogind}
++	LDLIBS += ${shell pkg-config --libs libelogind}
+ 	CPPFLAGS += -DENABLE_SYSTEMD
+ 	INSTALL_UDEV_RULES=0
+ 	MODE = 0755