diff mbox series

[bug#48977,4/4] gnu: Add openjdk16.

Message ID 20210612195449.13801-4-pierre.langlois@gmx.com
State Accepted
Headers show
Series Update openjdk 13 and later | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Pierre Langlois June 12, 2021, 7:54 p.m. UTC
* gnu/packages/java.scm (openjdk16): New variable.
---
 gnu/packages/java.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

--
2.32.0

Comments

Julien Lepiller June 13, 2021, 4:02 p.m. UTC | #1
Le Sat, 12 Jun 2021 20:54:49 +0100,
Pierre Langlois <pierre.langlois@gmx.com> a écrit :

> +    (arguments
> +     (substitute-keyword-arguments (package-arguments openjdk15)
> +       ((#:phases phases)
> +        `(modify-phases ,phases
> +           (add-after 'unpack 'make-templates-writable
> +             (lambda _
> +               ;; The build system copies a few .template files from
> the
> +               ;; source directory into the build directory and then
> modifies
> +               ;; them in-place. So these files have to be writable.
> +               (for-each
> +                (lambda (file)
> +                  (invoke "chmod" "u+w" file))
> +                (find-files
> "src/java.base/share/classes/jdk/internal/misc/"
> +                            "\\.template"))

Should be "\\.template$", otherwise the whole series LGTM!
Pierre Langlois June 13, 2021, 5:03 p.m. UTC | #2
Hi Julien,

Julien Lepiller writes:

> Le Sat, 12 Jun 2021 20:54:49 +0100,
> Pierre Langlois <pierre.langlois@gmx.com> a écrit :
>
>> +    (arguments
>> +     (substitute-keyword-arguments (package-arguments openjdk15)
>> +       ((#:phases phases)
>> +        `(modify-phases ,phases
>> +           (add-after 'unpack 'make-templates-writable
>> +             (lambda _
>> +               ;; The build system copies a few .template files from
>> the
>> +               ;; source directory into the build directory and then
>> modifies
>> +               ;; them in-place. So these files have to be writable.
>> +               (for-each
>> +                (lambda (file)
>> +                  (invoke "chmod" "u+w" file))
>> +                (find-files
>> "src/java.base/share/classes/jdk/internal/misc/"
>> +                            "\\.template"))
>
> Should be "\\.template$", otherwise the whole series LGTM!

Thanks for the review! Fixed and pushed with
afd4924d6a64c01a1d5138954b9f22c9bd4f4690.

Pierre
diff mbox series

Patch

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index af3e83be00..184393aaa3 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2540,6 +2540,44 @@  new Date();"))
        ("zip" ,zip)))
     (home-page "https://openjdk.java.net/projects/jdk/15")))

+(define-public openjdk16
+  (package
+    (inherit openjdk15)
+    (name "openjdk")
+    (version "16.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/openjdk/jdk16u")
+                    (commit (string-append "jdk-" version "-ga"))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1ggddsbsar4dj2fycfqqqagqil7prhb30afvq6933rz7pa9apm2f"))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("openjdk15:jdk" ,openjdk15 "jdk")
+       ("pkg-config" ,pkg-config)
+       ("unzip" ,unzip)
+       ("which" ,which)
+       ("zip" ,zip)))
+    (arguments
+     (substitute-keyword-arguments (package-arguments openjdk15)
+       ((#:phases phases)
+        `(modify-phases ,phases
+           (add-after 'unpack 'make-templates-writable
+             (lambda _
+               ;; The build system copies a few .template files from the
+               ;; source directory into the build directory and then modifies
+               ;; them in-place. So these files have to be writable.
+               (for-each
+                (lambda (file)
+                  (invoke "chmod" "u+w" file))
+                (find-files "src/java.base/share/classes/jdk/internal/misc/"
+                            "\\.template"))
+               #t))))))
+    (home-page "https://openjdk.java.net/projects/jdk/16")))
+
 (define-public icedtea icedtea-8)