diff mbox series

[bug#48953,v2,2/3] gnu: dino: Add missing inputs.

Message ID 20210611011550.27628-2-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#48953,v2,1/3] gnu: dino: Remove duplicate inputs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan June 11, 2021, 1:15 a.m. UTC
These new inputs are referenced by the package but was missing in
the package definition. Some of these inputs might have been used
by the package indirectly via propagation from other inputs.

* gnu/packages/messaging.scm (dino)[native-inputs]: Add gobject-introspection.
[inputs]: Add atk, cairo, gdk-pixbug+svg, libcanberra, libnice and pango.
---
 gnu/packages/messaging.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

Comments

Jack Hill June 11, 2021, 3:31 a.m. UTC | #1
On Thu, 10 Jun 2021, Raghav Gururajan via Guix-patches via wrote:

> These new inputs are referenced by the package but was missing in
> the package definition. Some of these inputs might have been used
> by the package indirectly via propagation from other inputs.

Cool, thanks for working on improving Dino.

> * gnu/packages/messaging.scm (dino)[native-inputs]: Add gobject-introspection.
> [inputs]: Add atk, cairo, gdk-pixbug+svg, libcanberra, libnice and pango.
> ---
> gnu/packages/messaging.scm | 9 ++++++++-
> 1 file changed, 8 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
> index d85577e76c..5be733f3a2 100644
> --- a/gnu/packages/messaging.scm
> +++ b/gnu/packages/messaging.scm

[…]

> +       ("libcanberra" ,libcanberra)

I think canberra support is disabled by default even if the dependency is 
present. I found the following configure-flags enable it:

#:configure-flags (list "-DDINO_PLUGIN_ENABLED_notification-sound=yes")

Now I'm curious to find out from upstream why it's not enabled by default 
and if that should affect whether we enable it in Guix.

Best,
Jack
Jack Hill June 11, 2021, 3:06 p.m. UTC | #2
On Thu, 10 Jun 2021, Jack Hill wrote:

> On Thu, 10 Jun 2021, Raghav Gururajan via Guix-patches via wrote:
>
>> +       ("libcanberra" ,libcanberra)
>
> I think canberra support is disabled by default even if the dependency is 
> present. I found the following configure-flags enable it:
>
> #:configure-flags (list "-DDINO_PLUGIN_ENABLED_notification-sound=yes")
>
> Now I'm curious to find out from upstream why it's not enabled by default and 
> if that should affect whether we enable it in Guix.

I asked about this in Dino's chat room⁰ and they said that the 
notification-sound plugin is not ready to be enabled by distros¹.

⁰ <xmpp:chat@dino.im?join>
¹ https://github.com/dino/dino/issues/578#issuecomment-581863288

Best,
Jack
Raghav Gururajan June 17, 2021, 12:17 a.m. UTC | #3
Hi Jackhill!

> I think canberra support is disabled by default even if the dependency 
> is present. I found the following configure-flags enable it:
> 
> #:configure-flags (list "-DDINO_PLUGIN_ENABLED_notification-sound=yes")
> 
> Now I'm curious to find out from upstream why it's not enabled by 
> default and if that should affect whether we enable it in Guix.

Ah thanks! I have moved this to 3rd patch, for enabling it in v0.3.0 update.

Regards,
RG.
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index d85577e76c..5be733f3a2 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1246,19 +1246,26 @@  Encryption to Gajim.")
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("glib:bin" ,glib "bin")
+       ("gobject-introspection" ,gobject-introspection)
        ("gtk+:bin" ,gtk+ "bin")
        ("pkg-config" ,pkg-config)
        ("vala" ,vala)))
     (inputs
-     `(("glib" ,glib)
+     `(("atk" ,atk)
+       ("cairo" ,cairo)
+       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("glib" ,glib)
        ("glib-networking" ,glib-networking)
        ("gpgme" ,gpgme)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("gtk+" ,gtk+)
+       ("libcanberra" ,libcanberra)
        ("libgcrypt" ,libgcrypt)
        ("libgee" ,libgee)
+       ("libnice" ,libnice)
        ("libsignal-protocol-c" ,libsignal-protocol-c)
        ("libsoup" ,libsoup)
+       ("pango" ,pango)
        ("qrencode" ,qrencode)
        ("sqlite" ,sqlite)))
     (synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")