diff mbox series

[bug#48952,3/3] gnu: Add librerama.

Message ID 20210611005546.429055-3-monego@posteo.net
State New
Headers show
Series build-system: Add godot-build-system. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego June 11, 2021, 12:55 a.m. UTC
* gnu/packages/games.scm (librerama): New variable.
---
 gnu/packages/games.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 55f468da2c..40ae8de80c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2491,6 +2491,45 @@  available, as well as a single-player mode with AI-controlled ships.")
     (license (list license:expat         ; game
                    license:silofl1.1)))) ; fonts
 
+(define-public librerama
+  (package
+    (name "librerama")
+    (version "0.4.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://codeberg.org/Yeldham/librerama")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "16hx09vbdsh27vwkgfmbhl1s5zkkmnyrirryz420kzlvmf5igsvy"))))
+    (build-system godot-build-system)
+    (arguments
+     `(#:game ,name
+       #:export-name "GNU/Linux / *BSD - 32 Bits"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'install-desktop-file
+           (lambda* (#:key inputs outputs game #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (share (string-append out "/share"))
+                    (applications (string-append share "/applications")))
+               (mkdir-p applications)
+               (with-directory-excursion "export/freedesktop"
+                 (copy-file "io.yeldham.librerama.desktop"
+                            (string-append applications "/" game
+                                           ".desktop")))))))))
+    (home-page "https://yeldham.itch.io/librerama")
+    (synopsis "Fast-paced arcade collection of mini-games")
+    (description
+     "Librerama is an arcade compilation of small, fast-paced games, with the
+overall objective being to play a series of mini-games (here referred as
+\"nanogames\") which progressively increase in speed and difficulty.")
+    (license (list license:gpl3+         ; game
+                   license:cc-by-sa4.0   ; assets
+                   license:silofl1.1)))) ; fonts
+
 (define %ufoai-commit "a542a87a891f96b1ab2c44d35b2f6f16859a5019")
 (define %ufoai-revision "0")
 (define %ufoai-version (git-version "2.6.0_dev" %ufoai-revision %ufoai-commit))