diff mbox series

[bug#48729,v3,32/47] gnu: Add go-github-com-oxtoacart-bpool.

Message ID 20210609170022.8207-32-rg@raghavgururajan.name
State Accepted
Headers show
Series None | expand

Commit Message

Raghav Gururajan June 9, 2021, 5 p.m. UTC
* gnu/packages/golang.scm (go-github-com-oxtoacart-bpool): New variable.
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4886a0d326..eaca6b9351 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -69,6 +69,34 @@ 
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
 
+(define-public go-github-com-oxtoacart-bpool
+  (let ((commit "03653db5a59cd88b481403d312d7c324b56af377")
+        (revision "18"))
+    (package
+      (name "go-github-com-oxtoacart-bpool")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/oxtoacart/bpool")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1crdgm5w6kvcnvdglrrnrfkh5h60ldafwvrv00q97lz3790kgb15"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/oxtoacart/bpool"))
+      (native-inputs
+       `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)))
+      (synopsis "Buffer/Byte pool for Go")
+      (description "Bpool implements leaky pools of byte arrays and buffers as
+bounded channels.  It is based on the leaky buffer example from the Effective Go
+documentation.")
+      (home-page "https://github.com/oxtoacart/bpool")
+      (license license:asl2.0))))
+
 (define-public go-github-com-getlantern-errors
   (package
     (name "go-github-com-getlantern-errors")