diff mbox series

[bug#48729,v3,16/47] gnu: Add go-github-com-mufti1-interconv.

Message ID 20210608231039.17819-16-rg@raghavgururajan.name
State Accepted
Headers show
Series : Bitmask VPN | expand

Commit Message

Raghav Gururajan June 8, 2021, 11:10 p.m. UTC
* gnu/packages/golang.scm (go-github-com-mufti1-interconv): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f6db72054e..9d2d092269 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -69,6 +69,31 @@ 
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
 
+(define-public go-github-com-mufti1-interconv
+  (let ((commit "d7c72925c6568d60d361757bb9f2d252dcca745c")
+        (revision "28"))
+    (package
+      (name "go-github-com-mufti1-interconv")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/mufti1/interconv")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "13f5pvr74afa28pbpmgvjzjx68vv5zmrwlvxp7hr5bl5625zlxmy"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:unpack-path "github.com/mufti1/interconv"
+         #:import-path "github.com/mufti1/interconv/package"))
+      (synopsis "Convert interface into any data type")
+      (description "Convert interface into any data type.")
+      (home-page "https://github.com/mufti1/interconv")
+      (license license:expat))))
+
 (define-public go-github-com-opentracing-opentracing-go
   (package
     (name "go-github-com-opentracing-opentracing-go")