diff mbox series

[bug#48850,v2] gnu: coreutils: Disable inotify-dir-recreate test

Message ID 20210607215058.3989424-1-contact@carldong.me
State Accepted
Headers show
Series [bug#48850,v2] gnu: coreutils: Disable inotify-dir-recreate test | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Carl Dong June 7, 2021, 9:50 p.m. UTC
> I’d write it like this:
> 
>  (lambda _
>    ,@(if (hurd-target?)
>          '((substitute* …))
>          '())
> 
>    …)

I'm not entirely familiar with the quoting here, but I trust that this is
correct... Does the following patch look okay?

---

This test fails on filesystems where tail detects that it cannot use
inotify safely. See https://issues.guix.gnu.org/47935 for more details.

* gnu/packages/base.scm (coreutils)[phases]: Disable
  inotify-dir-recreate tests.
---
 gnu/packages/base.scm | 18 +++++++++++-------
 1 file changed, 11 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index d30299a7b6..1ab50dfaf9 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -378,13 +378,17 @@  used to apply commands with arbitrarily long arguments.")
                        (("/bin/sh") (which "sh")))
                      (substitute* (find-files "tests" "\\.sh$")
                        (("#!/bin/sh") (string-append "#!" (which "sh"))))))
-                 ,@(if (hurd-target?)
-                       `((add-after 'unpack 'remove-tests
-                           (lambda _
-                             (substitute* "Makefile.in"
-                               ;; this test hangs
-                               (("^ *tests/misc/timeout-group.sh.*") "")))))
-                       '()))))
+                 (add-after 'unpack 'remove-tests
+                   (lambda _
+                     ,@(if (hurd-target?)
+                         '(substitute* "Makefile.in"
+                           ;; this test hangs
+                            (("^ *tests/misc/timeout-group.sh.*") ""))
+                         '())
+                     (substitute* "Makefile.in"
+                       ;; fails on filesystems where inotify cannot be used,
+                       ;; more info in #47935
+                       (("^ *tests/tail-2/inotify-dir-recreate.sh.*") "")))))))
    (synopsis "Core GNU utilities (file, text, shell)")
    (description
     "GNU Coreutils package includes all of the basic command-line tools that