diff mbox series

[bug#48886] New package: ack

Message ID 20210606194936.21986-1-ryan@arctype.co
State Accepted
Headers show
Series [bug#48886] New package: ack | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Ryan Sundberg June 6, 2021, 7:49 p.m. UTC
ack is a grep-like source code search tool.

Signed-off-by: Ryan Sundberg <ryan@arctype.co>
---
 gnu/packages/search.scm | 30 +++++++++++++++++++++++++++++-
 1 file changed, 29 insertions(+), 1 deletion(-)

Comments

Simon Tournier June 23, 2021, 3:12 p.m. UTC | #1
Hi,

On Sun, 06 Jun 2021 at 12:49, Ryan Sundberg <ryan@arctype.co> wrote:
> ack is a grep-like source code search tool.
>
> Signed-off-by: Ryan Sundberg <ryan@arctype.co>
> ---
>  gnu/packages/search.scm | 30 +++++++++++++++++++++++++++++-
>  1 file changed, 29 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
> index 362eb0d95e..a131678936 100644
> --- a/gnu/packages/search.scm
> +++ b/gnu/packages/search.scm

Exactly the same as #48893; already commented.  Therefore, closing this one.

<http://issues.guix.gnu.org/issue/48893>

All the best,
simon
diff mbox series

Patch

diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 362eb0d95e..a131678936 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -6,6 +6,7 @@ 
 ;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Adam Massmann <massmannak@gmail.com>
 ;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2021 Ryan Sundberg <ryan@arctype.co>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -24,11 +25,12 @@ 
 
 (define-module (gnu packages search)
   #:use-module ((guix licenses)
-                #:select (gpl2 gpl2+ gpl3+ lgpl2.1+ bsd-3 x11 perl-license))
+                #:select (gpl2 gpl2+ gpl3+ lgpl2.1+ bsd-3 x11 perl-license artistic2.0))
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix utils)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system python)
@@ -50,6 +52,32 @@ 
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xml))
 
+
+(define-public ack
+  (package
+    (name "ack")
+    (version "3.5.0")
+    (source 
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://beyondgrep.com/ack-v" version))
+        (sha256 (base32 "17wq9c1pwisbg4mcmvmdaym8hlawx209iriaxjlw9hwi0v4x6w38"))))
+    (inputs `(("perl" ,perl)))
+    (build-system copy-build-system)
+    (arguments 
+      `(#:install-plan '(("ack" "bin/ack"))
+        #:phases
+        (modify-phases %standard-phases
+          (replace 'unpack 
+                   (lambda* (#:key source #:allow-other-keys)
+                     (copy-file source "ack")
+                     (chmod "ack" #o0755)
+                     #t)))))
+    (home-page "https://github.com/protojure/protoc-plugin")
+    (synopsis "ack is a grep-like source code search tool.")
+    (description "Designed for programmers with large heterogeneous trees of source code, ack is written in portable Perl 5 and takes advantage of the power of Perl's regular expressions. ack is designed as an alternative to grep for programmers.")
+    (license artistic2.0)))
+
 (define-public xapian
   (package
     (name "xapian")