diff mbox series

[bug#48889,1/4] New package: bird bgp daemon, versions 1 and 2

Message ID 20210606185204.17617-1-ryan@arctype.co
State New
Headers show
Series [bug#48889,1/4] New package: bird bgp daemon, versions 1 and 2 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Ryan Sundberg June 6, 2021, 6:52 p.m. UTC
Adds the bird BGP daemon to gnu/packages/bird.scm
---
 gnu/packages/bird.scm | 74 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 74 insertions(+)
 create mode 100644 gnu/packages/bird.scm

Comments

M June 7, 2021, 9:35 a.m. UTC | #1
Hi,

Ryan Sundberg via Guix-patches via schreef op zo 06-06-2021 om 11:52 [-0700]:
> Adds the bird BGP daemon to gnu/packages/bird.scm

See commits (e.g. git log -n9) for how to format commit messages.

> ---
>  gnu/packages/bird.scm | 74 +++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 74 insertions(+)
>  create mode 100644 gnu/packages/bird.scm
> 
> diff --git a/gnu/packages/bird.scm b/gnu/packages/bird.scm
> new file mode 100644
> index 0000000000..5fac395906
> --- /dev/null
> +++ b/gnu/packages/bird.scm

Maybe gnu/packages/networking.scm, instead of creating a new
module for a single package.

> +        #:phases (modify-phases %standard-phases
> +                                ; Fix "cc not found" in tools/mergedirs
> +                                (add-after 'bootstrap 'set-cc
> +                                           (lambda _ 
> +                                             (setenv "CPP" "gcc -E")
> +                                             #t)))))

This most likely should be ,(string-append (cc-for-target) " -E"), to
make sure cross-compiling works. Also, the more declarative #:make-flags
is preferred above imperative setenv.

> +    (inputs
> +      `(("autoconf" ,autoconf)
> +        ("bison" ,bison)
> +        ("flex" ,flex)

autoconf, bison & flex most likely should be native inputs.

> +        ("ncurses" ,ncurses)
> +        ("readline" ,readline)))
> +    (home-page "http://bird.network.cz/")
> +    (synopsis "BIRD Internet Routing Daemon")
> +    (description "The BIRD project aims to develop a dynamic IP routing daemon with full support of all modern routing protocols, easy to use configuration interface and powerful route filtering language, primarily targeted on (but not limited to) Linux and other UNIX-like systems and distributed under the GNU General Public License.")
> +    (license gpl2+)))

The description line is too long.
./pre-inst-env guix lint bird@1.6.7 should detect that.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/bird.scm b/gnu/packages/bird.scm
new file mode 100644
index 0000000000..5fac395906
--- /dev/null
+++ b/gnu/packages/bird.scm
@@ -0,0 +1,74 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Ryan Sundberg <ryan@arctype.co>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages bird)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages bison)
+  #:use-module (gnu packages flex)
+  #:use-module (gnu packages ncurses)
+  #:use-module (gnu packages readline)
+  #:use-module (guix packages)
+  #:use-module (guix git-download)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix licenses))
+
+(define-public bird-1
+  (package
+    (name "bird")
+    (version "1.6.7")
+    (source 
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://gitlab.nic.cz/labs/bird.git")
+               (commit (string-append "v" version))))
+        (sha256 (base32 "0vbjp42c2zqmcrqcwm4g4fq1v93l6rlk0c27i0k08f3v07w75cih"))))
+    (build-system gnu-build-system)
+    (arguments
+      `(#:configure-flags '("--enable-ipv6")
+        #:tests? #f
+        #:phases (modify-phases %standard-phases
+                                ; Fix "cc not found" in tools/mergedirs
+                                (add-after 'bootstrap 'set-cc
+                                           (lambda _ 
+                                             (setenv "CPP" "gcc -E")
+                                             #t)))))
+    (inputs
+      `(("autoconf" ,autoconf)
+        ("bison" ,bison)
+        ("flex" ,flex)
+        ("ncurses" ,ncurses)
+        ("readline" ,readline)))
+    (home-page "http://bird.network.cz/")
+    (synopsis "BIRD Internet Routing Daemon")
+    (description "The BIRD project aims to develop a dynamic IP routing daemon with full support of all modern routing protocols, easy to use configuration interface and powerful route filtering language, primarily targeted on (but not limited to) Linux and other UNIX-like systems and distributed under the GNU General Public License.")
+    (license gpl2+)))
+
+(define-public bird
+  (package
+    (inherit bird-1)
+    (version "2.0.8")
+    (source 
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://gitlab.nic.cz/labs/bird.git")
+               (commit (string-append "v" version))))
+        (sha256 (base32 "07mh41hsmkcpf6f6lnygzp6g59jma542pcqdkl54ysiqnjmi5zz1"))))
+    (arguments
+      `(#:configure-flags '("--enable-ipv6")))))