diff mbox series

[bug#48862] gnu: python-hic2cool: Update to 0.8.3.

Message ID 20210606051407.6535-1-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#48862] gnu: python-hic2cool: Update to 0.8.3. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu June 6, 2021, 5:14 a.m. UTC
* gnu/packages/bioinformatics.scm (python-hic2cool): Update to 0.8.3.
---
 gnu/packages/bioinformatics.scm | 28 ++++++++++++++++++++++------
 1 file changed, 22 insertions(+), 6 deletions(-)

Comments

Mădălin Ionel Patrașcu June 6, 2021, 7:31 a.m. UTC | #1
Hey Guix,


I made some changes to the commit message, I omitted some important 
information.

I will send another patch. Sorry for this!


All the best,

      Mădălin!

On 06.06.2021 07:15, GNU bug Tracking System wrote:
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
>   guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 48862@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
Efraim Flashner June 7, 2021, 7:40 a.m. UTC | #2
I made a few changes before pushing the patch.

On Sun, Jun 06, 2021 at 07:14:07AM +0200, Mădălin Ionel Patrașcu wrote:
> * gnu/packages/bioinformatics.scm (python-hic2cool): Update to 0.8.3.

I mentioned that the download changed to use git-fetch, the added phase
and enabled tests, and the added inputs.

> ---
>  gnu/packages/bioinformatics.scm | 28 ++++++++++++++++++++++------
>  1 file changed, 22 insertions(+), 6 deletions(-)
> 
> diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
> index dab097381a..66e69ff2c8 100644
> --- a/gnu/packages/bioinformatics.scm
> +++ b/gnu/packages/bioinformatics.scm
> @@ -11892,18 +11892,34 @@ pyGenomeTracks can make plots with or without Hi-C data.")
>  (define-public python-hic2cool
>    (package
>      (name "python-hic2cool")
> -    (version "0.4.2")
> +    (version "0.8.3")
> +    ;; pypi sources do not contain the test_data directory and no test can be
> +    ;; run
>      (source
>       (origin
> -       (method url-fetch)
> -       (uri (pypi-uri "hic2cool" version))
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/4dn-dcic/hic2cool")
> +             (commit version)))
> +       (file-name (git-file-name name version))
>         (sha256
>          (base32
> -         "0xy6mhfns2lzib1kcr6419jjp6pmh0qx8z8na55lmiwn0ds8q9cl"))))
> +         "0dlnf0qfcp4jrc1nyya32a035c13xicyq16bwfnwhbb9s47mz7gl"))))
>      (build-system python-build-system)
> -    (arguments '(#:tests? #f)) ; no tests included
> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         ;;two of the test-data files need to be writable
> +         (add-after 'unpack 'patch-test-data
> +           (lambda* (#:key inputs outputs #:allow-other-keys)
> +             (chmod "test_data/hic2cool_0.4.2_single_res.cool" #o600)
> +             (chmod "test_data/hic2cool_0.7.0_multi_res.mcool" #o600))))))

I changed this one to be 'lambda _' and I changed the chmods to
make-file-writable.

>      (propagated-inputs
> -     `(("python-cooler" ,python-cooler)))
> +     `(("python-cooler" ,python-cooler)
> +       ("python-h5py" ,python-h5py)
> +       ("python-numpy" ,python-numpy)
> +       ("python-pandas" ,python-pandas)
> +       ("python-scipy" ,python-scipy)))
>      (home-page "https://github.com/4dn-dcic/hic2cool")
>      (synopsis "Converter for .hic and .cool files")
>      (description
> -- 
> 2.31.1
> 
> 
> 
>
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index dab097381a..66e69ff2c8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11892,18 +11892,34 @@  pyGenomeTracks can make plots with or without Hi-C data.")
 (define-public python-hic2cool
   (package
     (name "python-hic2cool")
-    (version "0.4.2")
+    (version "0.8.3")
+    ;; pypi sources do not contain the test_data directory and no test can be
+    ;; run
     (source
      (origin
-       (method url-fetch)
-       (uri (pypi-uri "hic2cool" version))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/4dn-dcic/hic2cool")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "0xy6mhfns2lzib1kcr6419jjp6pmh0qx8z8na55lmiwn0ds8q9cl"))))
+         "0dlnf0qfcp4jrc1nyya32a035c13xicyq16bwfnwhbb9s47mz7gl"))))
     (build-system python-build-system)
-    (arguments '(#:tests? #f)) ; no tests included
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;;two of the test-data files need to be writable
+         (add-after 'unpack 'patch-test-data
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (chmod "test_data/hic2cool_0.4.2_single_res.cool" #o600)
+             (chmod "test_data/hic2cool_0.7.0_multi_res.mcool" #o600))))))
     (propagated-inputs
-     `(("python-cooler" ,python-cooler)))
+     `(("python-cooler" ,python-cooler)
+       ("python-h5py" ,python-h5py)
+       ("python-numpy" ,python-numpy)
+       ("python-pandas" ,python-pandas)
+       ("python-scipy" ,python-scipy)))
     (home-page "https://github.com/4dn-dcic/hic2cool")
     (synopsis "Converter for .hic and .cool files")
     (description