diff mbox series

[bug#46955,2/3] gnu: Add python-ipytree.

Message ID 20210606000651.28252-2-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#46955,1/3] gnu: Add python-sparse. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu June 6, 2021, 12:06 a.m. UTC
* gnu/packages/python-xyz.scm (python-ipytree): New variable.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Ricardo Wurmus June 6, 2021, 6:23 a.m. UTC | #1
Hi Mădălin,

> * gnu/packages/python-xyz.scm (python-ipytree): New variable.

ipytree contains minified JavaScript that should be built from 
source instead.  We can usually minify JavaScript sources with 
esbuild.

Could you please check if the sources for all minified JavaScript 
are included and then

1. delete all minified JavaScript in a source snippet
2. add a build phase to minify the JavaScript from readable source 
code?

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a4fe31a01f..8ee43b1176 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7582,6 +7582,32 @@  away.")
 (define-public python2-ipython-genutils
   (package-with-python2 python-ipython-genutils))
 
+(define-public python-ipytree
+  (package
+    (name "python-ipytree")
+    (version "0.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ipytree" version))
+       (sha256
+        (base32
+         "0ss64kxa4la50irf7vy3474f1p924pn4da5gmb02zvhn2x0pra2j"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (propagated-inputs
+     `(("python-ipywidgets" ,python-ipywidgets)
+       ("python-jupyter-packaging" ,python-jupyter-packaging)))
+    (home-page "https://github.com/martinRenou/ipytree")
+    (synopsis "Tree widget using jsTree and Jupyter-widgets")
+    (description
+     "This package provides the possibility to create a tree using
+@code{Jupyter-widgets} protocol and @code{jsTree}.  @code{Jupyter-widgets} is a
+way to create an interactive @dfn{graphical user interface} (GUI) for a Jupyter
+notebook.  @code{JsTree} is a jquery plugin, that provides interactive trees.")
+    (license license:expat)))
+
 (define-public python-ipyparallel
   (package
     (name "python-ipyparallel")