diff mbox series

[bug#48846,core-updates,2/2] gnu: kmod: Add zstd support.

Message ID 20210605110224.8476-2-brice@waegenei.re
State Accepted
Headers show
Series Update kmod to 29 and add zstd support | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Brice Waegeneire June 5, 2021, 11:02 a.m. UTC
* gnu/packages/linux.scm (kmod)[inputs]: Add zstd:lib.
[arguments]: Enable zstd support.
---
 gnu/packages/linux.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ec223680fb..fe16325913 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3379,9 +3379,10 @@  to use Linux' inotify mechanism, which allows file accesses to be monitored.")
        ("zstd" ,zstd)))
     (inputs
      `(("xz" ,xz)
-       ("zlib" ,zlib)))
+       ("zlib" ,zlib)
+       ("zstd-lib" ,zstd "lib")))
     (arguments
-     `(#:configure-flags '("--with-xz" "--with-zlib"
+     `(#:configure-flags '("--with-xz" "--with-zlib" "--with-zstd"
                            "--disable-test-modules")
        #:phases
        (modify-phases %standard-phases