diff mbox series

[bug#48842,5/6] gnu: Add python-mdit-py-plugins.

Message ID 20210605014655.18459-5-monego@posteo.net
State New
Headers show
Series gnu: Add python-myst-parser. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego June 5, 2021, 1:46 a.m. UTC
* gnu/packages/python-xyz.scm (python-mdit-py-plugins): New variable.
---
 gnu/packages/python-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

Comments

Xinglu Chen June 5, 2021, 1:27 p.m. UTC | #1
On Sat, Jun 05 2021, Vinicius Monego wrote:

> * gnu/packages/python-xyz.scm (python-mdit-py-plugins): New variable.
> ---
>  gnu/packages/python-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
>  1 file changed, 37 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index fd7b1dd5f1..d357a92474 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -7150,6 +7150,43 @@ plugins.  Features:
>  @end itemize")
>      (license license:expat)))
>  
> +(define-public python-mdit-py-plugins
> +  (package
> +    (name "python-mdit-py-plugins")
> +    (version "0.2.8")
> +    (source
> +     (origin
> +       ;; There are no tests in the PyPI tarball.
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/executablebooks/mdit-py-plugins")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "0pq7cgzwb1gcbsdpdp51r3l6mnjdxc4hbfmwk6dy30pfa1lj6x1i"))))
> +    (build-system python-build-system)
> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (replace 'check
> +           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
> +             (when tests?
> +               (add-installed-pythonpath inputs outputs)
> +               (invoke "python" "-m" "pytest")))))))
> +    (propagated-inputs
> +     `(("python-markdown-it-py" ,python-markdown-it-py)))
> +    (native-inputs
> +     `(("python-coverage" ,python-coverage)
> +       ("python-pytest" ,python-pytest)
> +       ("python-pytest-cov" ,python-pytest-cov)
> +       ("python-pytest-regressions"
> +        ,python-pytest-regressions)))
> +    (home-page "https://github.com/executablebooks/mdit-py-plugins")
> +    (synopsis "Collection of plugins for markdown-it-py")
> +    (description
> +     "Collection of plugins for markdown-it-py.")

Please write a full sentence.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fd7b1dd5f1..d357a92474 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7150,6 +7150,43 @@  plugins.  Features:
 @end itemize")
     (license license:expat)))
 
+(define-public python-mdit-py-plugins
+  (package
+    (name "python-mdit-py-plugins")
+    (version "0.2.8")
+    (source
+     (origin
+       ;; There are no tests in the PyPI tarball.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/executablebooks/mdit-py-plugins")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0pq7cgzwb1gcbsdpdp51r3l6mnjdxc4hbfmwk6dy30pfa1lj6x1i"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "-m" "pytest")))))))
+    (propagated-inputs
+     `(("python-markdown-it-py" ,python-markdown-it-py)))
+    (native-inputs
+     `(("python-coverage" ,python-coverage)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-regressions"
+        ,python-pytest-regressions)))
+    (home-page "https://github.com/executablebooks/mdit-py-plugins")
+    (synopsis "Collection of plugins for markdown-it-py")
+    (description
+     "Collection of plugins for markdown-it-py.")
+    (license license:expat)))
+
 (define-public python-honcho
   (package
     (name "python-honcho")