diff mbox series

[bug#48838] gnu: nginx: Build with support for a few more modules.

Message ID 20210604202904.28218-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#48838] gnu: nginx: Build with support for a few more modules. | expand

Commit Message

Christopher Baines June 4, 2021, 8:29 p.m. UTC
I think this is generally useful. Personally, I want the HTTP gzip static and
gunzip ones for serving gzip compressed log files, and I spotted that the HTTP
sub and addition ones are easy to enable as well.

* gnu/packages/web.scm (nginx)[arguments]: Add the following configure flags:
--with-http_gzip_static_module, --with-http_gunzip_module,
--with-http_addition_module, --with-http_sub_module.
---
 gnu/packages/web.scm | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Ludovic Courtès June 8, 2021, 9 p.m. UTC | #1
Hi!

Christopher Baines <mail@cbaines.net> skribis:

> I think this is generally useful. Personally, I want the HTTP gzip static and
> gunzip ones for serving gzip compressed log files, and I spotted that the HTTP
> sub and addition ones are easy to enable as well.
>
> * gnu/packages/web.scm (nginx)[arguments]: Add the following configure flags:
> --with-http_gzip_static_module, --with-http_gunzip_module,
> --with-http_addition_module, --with-http_sub_module.

LGTM, thanks!

Ludo’.
Christopher Baines June 9, 2021, 8:12 a.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Hi!
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> I think this is generally useful. Personally, I want the HTTP gzip static and
>> gunzip ones for serving gzip compressed log files, and I spotted that the HTTP
>> sub and addition ones are easy to enable as well.
>>
>> * gnu/packages/web.scm (nginx)[arguments]: Add the following configure flags:
>> --with-http_gzip_static_module, --with-http_gunzip_module,
>> --with-http_addition_module, --with-http_sub_module.
>
> LGTM, thanks!

Great, pushed as 2d31eeecf06ab14732d374c75cdf6e7a55aa704e.

Thanks for taking a look!
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 4753eca8da..15befe7e6d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -399,6 +399,10 @@  the same, being completely separated from the Internet.")
                                   "--with-http_ssl_module"
                                   "--with-http_v2_module"
                                   "--with-http_xslt_module"
+                                  "--with-http_gzip_static_module"
+                                  "--with-http_gunzip_module"
+                                  "--with-http_addition_module"
+                                  "--with-http_sub_module"
                                   "--with-pcre-jit"
                                   "--with-debug"
                                   "--with-stream"