diff mbox series

[bug#46955,2/3] gnu: Add python-ipytree.

Message ID 20210603232503.29253-2-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#46955,1/3] gnu: Add python-sparse. | expand

Commit Message

Mădălin Ionel Patrașcu June 3, 2021, 11:25 p.m. UTC
* gnu/packages/python-xyz.scm (python-ipytree): New variable.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 35ce8d1cbe..f416e3a2a8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7568,6 +7568,32 @@  away.")
 (define-public python2-ipython-genutils
   (package-with-python2 python-ipython-genutils))
 
+(define-public python-ipytree
+  (package
+    (name "python-ipytree")
+    (version "0.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ipytree" version))
+       (sha256
+        (base32
+         "0ss64kxa4la50irf7vy3474f1p924pn4da5gmb02zvhn2x0pra2j"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (propagated-inputs
+     `(("python-ipywidgets" ,python-ipywidgets)
+       ("python-jupyter-packaging" ,python-jupyter-packaging)))
+    (home-page "https://github.com/martinRenou/ipytree")
+    (synopsis "Tree widget using jsTree and Jupyter-widgets")
+    (description
+     "This package provides the possibility to create a tree using
+@code{Jupyter-widgets} protocol and @code{jsTree}.  @code{Jupyter-widgets} is a
+way to create an interactive @dfn{graphical user interface} (GUI) for a Jupyter
+notebook.  @code{JsTree} is a jquery plugin, that provides interactive trees.")
+    (license license:expat)))
+
 (define-public python-ipyparallel
   (package
     (name "python-ipyparallel")