diff mbox series

[bug#48729,v2,41/47] gnu: Add go-github-com-go-gl-glow.

Message ID 20210603205110.7102-41-rg@raghavgururajan.name
State Accepted
Headers show
Series None | expand

Commit Message

Raghav Gururajan June 3, 2021, 8:51 p.m. UTC
* gnu/packages/golang.scm (go-github-com-go-gl-glow): New variable.
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7661813489..3a632b0705 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -74,6 +74,34 @@ 
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
 
+(define-public go-github-com-go-gl-glow
+  (let ((commit "640349a6105e64eb9e5085d2afee1ab2ec67d2dc")
+        (revision "300"))
+    (package
+      (name "go-github-com-go-gl-glow")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/go-gl/glow")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1lzibraqjkzibvxw1lagrlzpjsqbp5pd4fcyi6ygqhgja0ik3zd7"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/go-gl/glow"))
+      (propagated-inputs
+       `(("go-golang-org-x-tools" ,go-golang-org-x-tools)))
+      (home-page "https://github.com/go-gl/glow")
+      (synopsis "Go binding generator for OpenGL")
+      (description "Glow is an OpenGL binding generator for Go.  It parses the
+OpenGL XML API registry and the EGL XML API registry to produce a
+machine-generated cgo bridge between Go functions and native OpenGL functions.")
+      (license license:expat))))
+
 (define-public go-github-com-grd-glfw3
   (let ((commit "55390ea70f0d427a7ed40c26ea19e82fce17c927")
         (revision "100"))