diff mbox series

[bug#48729,v2,38/47] gnu: Add gtkspell2.

Message ID 20210603114657.30408-38-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#48729,v3,01/47] gnu: Add go-github-com-rakyll-statik. | expand

Commit Message

Raghav Gururajan June 3, 2021, 11:46 a.m. UTC
* gnu/packages/gtk.scm (gtkspell2): New variable.
---
 gnu/packages/gtk.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index e64dc69798..1ab8d57f30 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1914,6 +1914,33 @@  glass artworks done by Venicians glass blowers.")
 misspelled words in a GtkTextView widget.")
     (license license:gpl2+)))
 
+(define-public gtkspell2
+  (package
+    (inherit gtkspell3)
+    (name "gtkspell2")
+    (version "2.0.16")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/gtkspell/"
+                           version "/gtkspell-" version ".tar.gz"))
+       (sha256
+        (base32 "00hdv28bp72kg1mq2jdz1sdw2b8mb9iclsp7jdqwpck705bdriwg"))))
+    (arguments
+     `(#:configure-flags
+       (list
+        "--disable-static")))
+    (native-inputs
+     `(("gettext" ,gettext-minimal)
+       ("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)
+       ("xmllint" ,libxml2)))
+    (inputs
+     `(("enchant" ,enchant-1.6)
+       ("pango" ,pango)))
+    (propagated-inputs
+     `(("gtk+" ,gtk+-2)))))
+
 (define-public clipit
   (package
     (name "clipit")