diff mbox series

[bug#48729,v2,37/47] gnu: Add gtkglarea.

Message ID 20210603111118.26120-37-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#48729,v3,01/47] gnu: Add go-github-com-rakyll-statik. | expand

Commit Message

Raghav Gururajan June 3, 2021, 11:11 a.m. UTC
* gnu/packages/gnome.scm (gtkglarea): New variable.
---
 gnu/packages/gnome.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index be458c07bb..6cbe219102 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -218,6 +218,37 @@ 
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
 
+(define-public gtkglarea
+  (package
+    (name "gtkglarea")
+    (version "2.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "mirror://gnome/sources/" name "/"
+                       (version-major+minor version) "/"
+                       name "-" version ".tar.xz"))
+       (sha256
+        (base32 "1pl2vdj6l64j864ilhkq1bcggb3hrlxjwk5m029i7xfjfxc587lf"))))
+    (build-system glib-or-gtk-build-system)
+    (arguments
+     `(#:configure-flags
+       (list
+        "--disable-static")))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("mesa" ,mesa)))
+    (propagated-inputs
+     `(("gtk+" ,gtk+-2)))
+    (synopsis "OpenGL widget for GTK+")
+    (description "GtkGLArea is an OpenGL widget for GTK+ GUI toolkit.
+ Just as GTK+ is build on top of GDK, GtkGLArea is built on top of gdkgl which
+ is basically wrapper around GLX functions.")
+    (home-page "https://developer.gnome.org/gtk3/stable/GtkGLArea.html")
+    (license license:lgpl2.0+)))
+
 (define-public gupnp-igd
   (package
     (name "gupnp-igd")