diff mbox series

[bug#48729,v2,23/47] gnu: Add go-0xacab-org-leap-shapeshifter.

Message ID 20210603100249.21269-23-rg@raghavgururajan.name
State Accepted
Headers show
Series : Bitmask VPN | expand

Commit Message

Raghav Gururajan June 3, 2021, 10:02 a.m. UTC
* gnu/packages/golang.scm (go-0xacab-org-leap-shapeshifter): New variable.
---
 gnu/packages/golang.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cde1627477..d541b696be 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -69,6 +69,39 @@ 
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
 
+(define-public go-0xacab-org-leap-shapeshifter
+  (let ((commit "0aa6226582efb8e563540ec1d3c5cfcd19200474")
+        (revision "12"))
+    (package
+      (name "go-0xacab-org-leap-shapeshifter")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://0xacab.org/leap/shapeshifter")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0m4fla9ppl53k9syms4dsad92wakr74cdvids3xxv3amdh4d1w4i"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "0xacab.org/leap/shapeshifter"))
+      (propagated-inputs
+       `(("go-github-com-operatorfoundation-obfs4"
+          ,go-github-com-operatorfoundation-obfs4)
+         ("go-github-com-operatorfoundation-shapeshifter-transports"
+          ,go-github-com-operatorfoundation-shapeshifter-transports)
+         ("go-golang-org-x-net" ,go-golang-org-x-net)))
+      (synopsis "Network Obfuscater")
+      (description "Shapeshifter provides network protocol shapeshifting
+technology.  The purpose of this technology is to change the characteristics of
+network traffic so that it is not identified and subsequently blocked by network
+filtering devices.")
+      (home-page "https://0xacab.org/leap/shapeshifter")
+      (license license:bsd-2))))
+
 (define-public go-github-com-operatorfoundation-shapeshifter-transports
   (package
     (name "go-github-com-operatorfoundation-shapeshifter-transports")