diff mbox series

[bug#48786] gnu: Add udftools.

Message ID 20210601224250.30896-1-noisytoot@disroot.org
State Accepted
Headers show
Series [bug#48786] gnu: Add udftools. | expand

Commit Message

Ron Nazarov June 1, 2021, 10:42 p.m. UTC
* gnu/packages/linux.scm (udftools): New variable.
---
 gnu/packages/linux.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b803426b74..aaafd892a7 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -54,6 +54,7 @@ 
 ;;; Copyright © 2020 David Dashyan <mail@davie.li>
 ;;; Copyright © 2020 pukkamustard <pukkamustard@posteo.net>
 ;;; Copyright © 2021 B. Wilson <elaexuotee@wilsonb.com>
+;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5226,6 +5227,33 @@  small devices.  This version has additional features such as uncompressed
 blocks and random block placement.")
     (license license:gpl2+)))
 
+(define-public udftools
+  (package
+    (name "udftools")
+    (version "2.3")
+    (source (origin
+	      (method git-fetch)
+	      (uri (git-reference
+		    (url "https://github.com/pali/udftools")
+		    (commit version)))
+	      (sha256
+	       (base32
+	        "1nl2s61znyzaap23zhbdg3znj6l6akr313fchn5wwvjzj8k70is9"))
+              (file-name (git-file-name name version))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("automake" ,automake)
+       ("autoconf" ,autoconf)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/pali/udftools")
+    (synopsis "Tools to manage @acronym{UDF, Universal Disk Format} filesystems and DVD/CD-R(W) drives")
+    (description "@code{udftools} is a set of programs for reading
+and modifying @acronym{UDF, Universal Disk Format} filesystems.
+@acronym{UDF, Universal Disk Format} is a filesystem mostly used for DVDs and other optical media.
+It supports read-only media (DVD/CD-R) and rewritable media that wears out (DVD/CD-RW).")
+    (license license:gpl2+)))
+
 (define-public compsize
   (package
     (name "compsize")