diff mbox series

[bug#48784] gnu: python-asdf: Adjust inputs.

Message ID 20210601202634.73557-1-monego@posteo.net
State Accepted
Headers show
Series [bug#48784] gnu: python-asdf: Adjust inputs. | expand

Commit Message

Vinicius Monego June 1, 2021, 8:26 p.m. UTC
* gnu/packages/astronomy.scm (python-asdf)[native-inputs]: Remove python-semantic-version.
[inputs]: Move python-importlib-resources, python-jsonschema, python-numpy,
python-pyyaml ...
[propagated-inputs]: ... here. Add python-semantic-version.
---
 gnu/packages/astronomy.scm | 27 ++++++++++++++-------------
 1 file changed, 14 insertions(+), 13 deletions(-)

Comments

Mathieu Othacehe June 4, 2021, 12:14 p.m. UTC | #1
> * gnu/packages/astronomy.scm (python-asdf)[native-inputs]: Remove python-semantic-version.
> [inputs]: Move python-importlib-resources, python-jsonschema, python-numpy,
> python-pyyaml ...
> [propagated-inputs]: ... here. Add python-semantic-version.

Pushed as 990ace8714e6e2c7d54da819e9cca9ef863875e1.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 907541d5c8..2bee5cc32f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -6,6 +6,7 @@ 
 ;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
 ;;; Copyright © 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1099,21 +1100,21 @@  of stand-alone functions and classes.")
      ;; depends on asdf. Disable circular dependence.
      `(#:tests? #f))
     (native-inputs
-     `(("packaging" ,python-packaging)
-       ("semantic-version" ,python-semantic-version)
-       ("setuptools-scm" ,python-setuptools-scm)))
-     (inputs
-      `(("importlib-resources" ,python-importlib-resources)
-        ("jsonschema" ,python-jsonschema)
-        ("numpy" ,python-numpy)
-        ("pyyaml" ,python-pyyaml)))
-     (home-page "https://github.com/asdf-format/asdf")
-     (synopsis "Python tools to handle ASDF files")
-     (description
-      "The Advanced Scientific Data Format (ASDF) is a next-generation
+     `(("python-packaging" ,python-packaging)
+       ("python-setuptools-scm" ,python-setuptools-scm)))
+    (propagated-inputs
+     `(("python-importlib-resources" ,python-importlib-resources)
+       ("python-jsonschema" ,python-jsonschema)
+       ("python-numpy" ,python-numpy)
+       ("python-pyyaml" ,python-pyyaml)
+       ("python-semantic-version" ,python-semantic-version)))
+    (home-page "https://github.com/asdf-format/asdf")
+    (synopsis "Python tools to handle ASDF files")
+    (description
+     "The Advanced Scientific Data Format (ASDF) is a next-generation
 interchange format for scientific data.  This package contains the Python
 implementation of the ASDF Standard.")
-     (license license:bsd-3)))
+    (license license:bsd-3)))
 
 (define-public python-astroalign
   (package