diff mbox series

[bug#47768,v3,03/42] gnu: ocaml-ctypes: Make ocaml-integers a propagated input.

Message ID 20210601202325.8777-4-pukkamustard@posteo.net
State Accepted
Headers show
Series Assorted OCaml patches | expand

Commit Message

pukkamustard June 1, 2021, 8:22 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-ctypes)[propagated-inputs]: Add ocaml-integers.
  [inputs]: Remove ocaml-integers.
---
 gnu/packages/ocaml.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 46b5542864..7d467b3b70 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3863,11 +3863,11 @@  long and size_t whose sizes depend on the host platform.")
    (native-inputs
     `(("pkg-config" ,pkg-config)))
    (propagated-inputs
-    `(("bigarray-compat" ,ocaml-bigarray-compat)))
+    `(("bigarray-compat" ,ocaml-bigarray-compat)
+      ("integers" ,ocaml-integers)))
    (inputs
     `(("libffi" ,libffi)
       ("ounit" ,ocaml-ounit)
-      ("integers" ,ocaml-integers)
       ("lwt" ,ocaml-lwt)
       ("topkg" ,ocaml-topkg)
       ("opam" ,opam)))