diff mbox series

[bug#48772] gnu: Add lxcfs.

Message ID 20210601052553.GA27406@dm9.info
State Accepted
Headers show
Series [bug#48772] gnu: Add lxcfs. | expand

Commit Message

Dion Mendel June 1, 2021, 5:25 a.m. UTC
* gnu/packages/virtualization.scm (lxcfs): New Variable.
---
 gnu/packages/virtualization.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Ludovic Courtès June 5, 2021, 9:23 p.m. UTC | #1
Hi,

Dion Mendel <guix@dm9.info> skribis:

> * gnu/packages/virtualization.scm (lxcfs): New Variable.

[...]

> +    (license license:lgpl2.1)))

I changed it to ‘lgpl2.1+’ as noted in the code and applied.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index f12f862304..501a635a9a 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -19,6 +19,7 @@ 
 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2021 Dion Mendel <guix@dm9.info>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1065,6 +1066,35 @@  Through a powerful API and simple tools, it lets Linux users easily create and
 manage system or application containers.")
     (license license:lgpl2.1+)))
 
+(define-public lxcfs
+  (package
+    (name "lxcfs")
+    (version "4.0.8")
+    (home-page "https://github.com/lxc/lxcfs")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference (url home-page)
+                                  (commit (string-append "lxcfs-" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1f74wy88si2ia035pcvciq5821kc8jcb75w1f8vhbp0cd29rqdpi"))))
+    (arguments
+     '(#:configure-flags '("--localstatedir=/var")))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("fuse" ,fuse)))
+    (build-system gnu-build-system)
+    (synopsis "FUSE based filesystem for LXC")
+    (description "LXCFS is a small FUSE filesystem written with the intention
+of making Linux containers feel more like a virtual machine.
+It started as a side-project of LXC but is useable by any runtime.")
+    (license license:lgpl2.1)))
+
 (define-public libvirt
   (package
     (name "libvirt")