diff mbox series

[bug#48671,01/11] gnu: Add nitrocli.

Message ID 20210530214212.11807-1-antero@kodmin.com
State Accepted
Headers show
Series [bug#48671,01/11] gnu: Add nitrocli. | expand

Commit Message

Antero Mejr May 30, 2021, 9:42 p.m. UTC
* gnu/packages/security-token.scm (nitrocli): New variable.
---
Thanks for the feedback Xinglu, I updated the package descriptions and linted.
Resubmitting the patches as separate commits.

 gnu/packages/security-token.scm | 43 +++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)

Comments

Xinglu Chen May 31, 2021, 9:05 p.m. UTC | #1
On Sun, May 30 2021, Antero Mejr wrote:

> * gnu/packages/security-token.scm (nitrocli): New variable.
> ---
> Thanks for the feedback Xinglu, I updated the package descriptions and linted.
> Resubmitting the patches as separate commits.
>
>  gnu/packages/security-token.scm | 43 +++++++++++++++++++++++++++++++++
>  1 file changed, 43 insertions(+)

The package builds fine on my end, the patches I haven’t commented on
look good.

Could you send a updated (hopefully final) series? :)
diff mbox series

Patch

diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index dfa43bb2bf..fcb1123f2b 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -674,3 +674,46 @@  that after installing this package, you might still need to add appropriate
 udev rules to your system configuration to be able to configure the YubiKey as
 an unprivileged user.")
     (license license:bsd-2)))
+
+(define-public nitrocli
+  (package
+    (name "nitrocli")
+    (version "0.4.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "nitrocli" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1djspfvcqjipg17v8hkph8xrhkdg1xqjhq5jk1sr8vr750yavidy"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f ;; 2/164 tests fail, nitrocli-ext tests failing
+       #:cargo-inputs
+       (("rust-anyhow" ,rust-anyhow-1)
+        ("rust-base32" ,rust-base32-0.4)
+        ("rust-directories" ,rust-directories-3)
+        ("rust-envy" ,rust-envy-0.4)
+        ("rust-libc-0.2" ,rust-libc-0.2)
+        ("rust-merge" ,rust-merge-0.1)
+        ("rust-nitrokey" ,rust-nitrokey-0.9)
+        ("rust-progressing" ,rust-progressing-3)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-structopt" ,rust-structopt-0.3.21)
+        ("rust-termion" ,rust-termion-1)
+        ("rust-toml" ,rust-toml-0.5))
+       #:cargo-development-inputs
+       (("rust-nitrokey-test" ,rust-nitrokey-test-0.5)
+        ("rust-nitrokey-test-state" ,rust-nitrokey-test-state-0.1)
+        ("rust-regex" ,rust-regex-1)
+        ("rust-tempfile" ,rust-tempfile-3))))
+    (inputs
+     `(("hidapi" ,hidapi)
+       ("gnupg" ,gnupg)))
+    (home-page "https://github.com/d-e-s-o/nitrocli")
+    (synopsis "Command line tool for Nitrokey devices")
+    (description
+     "nitrocli is a program that provides a command line interface
+for interaction with Nitrokey Pro, Nitrokey Storage, and Librem Key
+devices.")
+    (license license:gpl3+)))