diff mbox series

[bug#48733] gnu: Add emacs-eyebrowse.

Message ID 20210529213918.217264-1-stefan@xsteve.at
State Accepted
Headers show
Series [bug#48733] gnu: Add emacs-eyebrowse. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör May 29, 2021, 9:39 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-eyebrowse): New variable.
---
 gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Nicolas Goaziou May 31, 2021, 7:06 p.m. UTC | #1
Hello,

Stefan Reichör <stefan@xsteve.at> writes:

> * gnu/packages/emacs-xyz.scm (emacs-eyebrowse): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2bd75c0dde..78a38c530b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7979,6 +7979,35 @@  perspective only its buffers are available by default.")
 can be saved to and restored from a file.")
     (license license:gpl2+)))
 
+(define-public emacs-eyebrowse
+  ;; XXX: Upstream has no tagged release.  Version is extracted from keyword
+  ;; in main file.
+  (let ((commit "88c7b59aa7c5c93bc23812217213adfa238f977b")
+        (revision "0"))
+    (package
+      (name "emacs-eyebrowse")
+      (version (git-version "0.7.8" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://depp.brause.cc/eyebrowse.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "09s07mvg5bz3dm9sxgn40c7z6d6ry1sdjzsxwgmy825f3xm66avs"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-dash" ,emacs-dash)))
+    (home-page "https://depp.brause.cc/eyebrowse/")
+    (synopsis "Simple-minded way to manage window configs in Emacs")
+    (description
+     "Eyebrowse is a global minor mode for Emacs that allows you to manage
+your window configurations in a simple manner, just like tiling window
+managers like i3wm with their workspaces do.  It displays their current state
+in the modeline by default.")
+    (license license:gpl3+))))
+
 (define-public emacs-test-simple
   (package
     (name "emacs-test-simple")