diff mbox series

[bug#48427] gnu: Add python-aiostream.

Message ID 20210529203841.157978-1-stefan@xsteve.at
State New
Headers show
Series [bug#48427] gnu: Add python-aiostream. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör May 29, 2021, 8:38 p.m. UTC
* gnu/packages/python-xyz.scm (python-aiostream): New variable.
---
Vinicius, thanks for your review.
Here is my attempt to follow your hints

 gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Jelle Licht May 29, 2023, 11:17 a.m. UTC | #1
Stefan Reichör <stefan@xsteve.at> writes:

> * gnu/packages/python-xyz.scm (python-aiostream): New variable.
[snip]

Superseded by commit ed18b697c4783f139e23731f5bd0b0ed197997bb, closing.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9b9510f043..a465ecbda6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20232,6 +20232,35 @@  generators and Python 3.7's context managers into Python 3.5.")
 manager compatible with @code{asyncio}.")
     (license license:asl2.0)))
 
+(define-public python-aiostream
+  (package
+    (name "python-aiostream")
+    (version "0.4.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/vxgmichel/aiostream")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1r3x9qwl08yscmzvhafc6gsmq84lr17s6p7a1qxr49cmdvjzsc13"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:test-target "pytest"))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-asyncio" ,python-pytest-asyncio)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-runner" ,python-pytest-runner)))
+    (home-page "https://github.com/vxgmichel/aiostream")
+    (synopsis "Generator-based operators for asynchronous iteration")
+    (description "aiostream provides a collection of stream operators that can
+be combined to create asynchronous pipelines of operations.  It can be seen as
+an asynchronous version of itertools, although some aspects are slightly
+different.")
+    (license license:gpl3)))
+
 (define-public python-glob2
   (package
     (name "python-glob2")