diff mbox series

[bug#48729,v1,14/24] gnu: Add go-github-com-operatorfoundation-monolith-go.

Message ID 20210529111538.23666-14-rg@raghavgururajan.name
State Accepted
Headers show
Series : Bitmask VPN | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan May 29, 2021, 11:15 a.m. UTC
* gnu/packages/golang.scm (go-github-com-operatorfoundation-monolith-go): New variable.
---
 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 93295bd3c7..c1d9610f95 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -67,6 +67,33 @@ 
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
 
+(define-public go-github-com-operatorfoundation-monolith-go
+  (package
+    (name "go-github-com-operatorfoundation-monolith-go")
+    (version "1.0.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/OperatorFoundation/monolith-go")
+         (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "066bqlgw5h7a3kxswqlv734asb7nw2y6snsn09yqk0ixj23qw22s"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:tests? #f ; ERROR: Generated bytes do not match correct answer.
+       #:unpack-path "github.com/OperatorFoundation/monolith-go"
+       #:import-path "github.com/OperatorFoundation/monolith-go/monolith"))
+    (propagated-inputs
+     `(("go-github-com-deckarep-golang-set"
+        ,go-github-com-deckarep-golang-set)))
+    (home-page "https://github.com/OperatorFoundation/monolith-go")
+    (synopsis "Go library for working with byte sequences")
+    (description "monolith-go is a Go library for working with byte sequences.")
+    (license license:expat)))
+
 (define-public go-github-com-deckarep-golang-set
   (package
     (name "go-github-com-deckarep-golang-set")