diff mbox series

[bug#48508] gnu: Add xjobs.

Message ID 20210518205743.137731-1-stefan@xsteve.at
State Accepted
Headers show
Series [bug#48508] gnu: Add xjobs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör May 18, 2021, 8:57 p.m. UTC
* gnu/packages/parallel.scm (xjobs): New variable.
---
 gnu/packages/parallel.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Ludovic Courtès May 28, 2021, 9:04 p.m. UTC | #1
Stefan Reichör <stefan@xsteve.at> skribis:

> * gnu/packages/parallel.scm (xjobs): New variable.

[...]

> +    (license license:gpl2)))

Changed to ‘gpl2+’, as per source file headers, and applied.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index 17e2a7f7fe..9cb915fcc6 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -41,6 +41,7 @@ 
   #:use-module (gnu packages admin)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages flex)
   #:use-module (gnu packages freeipmi)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages mpi)
@@ -135,6 +136,32 @@  execution is also possible.")
     (home-page "https://github.com/leahneukirchen/xe")
     (license license:public-domain)))
 
+(define-public xjobs
+  (package
+    (name "xjobs")
+    (version "20200726")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://www.maier-komor.de/xjobs/xjobs-"
+                    version ".tgz"))
+              (sha256
+               (base32
+                "0ay6gn43pnm7r1jamwgpycl67bjg5n87ncl27jb01w2x6x70z0i3"))))
+    (build-system gnu-build-system)
+    (arguments `(#:tests? #f)) ;; No tests
+    (native-inputs
+     `(("flex" ,flex)
+       ("which" ,which)))
+    (home-page "http://www.maier-komor.de/xjobs.html")
+    (synopsis
+     "Parallel execution of jobs with several useful options")
+    (description
+     "xjobs reads job descriptions line by line and executes them in
+parallel.  It limits the number of parallel executing jobs and starts new jobs
+when jobs finish.")
+    (license license:gpl2)))
+
 (define-public slurm
   (package
    (name "slurm")