diff mbox series

[bug#48502] gnu: luakit: Update to 2.3.

Message ID 20210518164940.31968-1-raphael.melotte@mind.be
State Accepted
Headers show
Series [bug#48502] gnu: luakit: Update to 2.3. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Raphaël Mélotte May 18, 2021, 4:49 p.m. UTC
* gnu/packages/web-browsers.scm (luakit): Update to 2.3
[arguments]: Add 'set-version' phase.
---
 gnu/packages/web-browsers.scm | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

Comments

Ludovic Courtès May 22, 2021, 9:37 p.m. UTC | #1
Hi,

Raphaël Mélotte <raphael.melotte@mind.be> skribis:

> * gnu/packages/web-browsers.scm (luakit): Update to 2.3
> [arguments]: Add 'set-version' phase.

[...]

> +         (add-before 'build 'set-version
> +           (lambda _
> +             (setenv "VERSION_FROM_GIT" ,(package-version luakit))

I changed this to (package-version this-package), which works also when
inheriting from the package, and applied.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 6b6ca78960..0546ab1caf 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -231,7 +231,7 @@  features including, tables, builtin image display, bookmarks, SSL and more.")
 (define-public luakit
   (package
     (name "luakit")
-    (version "2.2")
+    (version "2.3")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -240,7 +240,7 @@  features including, tables, builtin image display, bookmarks, SSL and more.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0km5nxn6innzn8pfsvlkxvfj2z5g46fp6dy5bnmaklbn13mqlcrn"))))
+                "1khbn7dpizkznnwkw7rcfhf72dnd1nazk7dwb4rkh9i97b53mf1y"))))
     (inputs
      `(("lua-5.1" ,lua-5.1)
        ("gtk+" ,gtk+)
@@ -254,7 +254,7 @@  features including, tables, builtin image display, bookmarks, SSL and more.")
      `(("pkg-config" ,pkg-config)))
     (build-system glib-or-gtk-build-system)
     (arguments
-     '(#:make-flags
+     `(#:make-flags
        (let ((out (assoc-ref %outputs "out")))
          (list
           "CC=gcc"
@@ -271,6 +271,10 @@  features including, tables, builtin image display, bookmarks, SSL and more.")
                       (assoc-ref %build-inputs "lua5.1-filesystem")
                       "/lib/lua/5.1/?.so;;"))
              #t))
+         (add-before 'build 'set-version
+           (lambda _
+             (setenv "VERSION_FROM_GIT" ,(package-version luakit))
+             #t))
          (delete 'configure)
          (delete 'check)
          (add-after 'install 'wrap