diff mbox series

[bug#48483,1/1] gnu: emacs-libyaml: fix broken phase.

Message ID 20210517173628.54883-1-plattfot@posteo.net
State Accepted
Headers show
Series Fix broken emacs-libyaml | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Fredrik Salomonsson May 17, 2021, 5:36 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-libyaml): Change
substitute-libyaml-core-path phase to be added after the unpack phase. As the
add-source-to-load-path phase which it was added to before seems to been
removed, which resulted in the phase not being run.
---
 gnu/packages/emacs-xyz.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Leo Prikler May 17, 2021, 6:02 p.m. UTC | #1
Pushed with the adjustments listed below:

Am Montag, den 17.05.2021, 17:36 +0000 schrieb Fredrik Salomonsson:
> * gnu/packages/emacs-xyz.scm (emacs-libyaml): Change
> substitute-libyaml-core-path phase to be added after the unpack
> phase. As the
> add-source-to-load-path phase which it was added to before seems to
> been
> removed, which resulted in the phase not being run.
I've rewritten the header so as to not contain "fix" (there has been
recent discussion to avoid said word unless necessary), and simplified
this line as well.
> ---
>  gnu/packages/emacs-xyz.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 7a62b6b7ef..6f67083d01 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -22533,7 +22533,7 @@ utilities.")
>  (define-public emacs-libyaml
>    ;; Upstream made no release so far.
>    (let ((version "0")
> -        (revision "1")
> +        (revision "2")
>          (commit "703e0d448c7ee24e25b513a3c65980c80e166805"))
>      (package
>        (name "emacs-libyaml")
You don't need to change the revision if the source has not changed.

Regards,
Leo
Fredrik Salomonsson May 17, 2021, 6:43 p.m. UTC | #2
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> I've rewritten the header so as to not contain "fix" (there has been
> recent discussion to avoid said word unless necessary), and simplified
> this line as well.

Thanks for cleaning up my commit message and merging it!

> You don't need to change the revision if the source has not changed.

Noted.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7a62b6b7ef..6f67083d01 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22533,7 +22533,7 @@  utilities.")
 (define-public emacs-libyaml
   ;; Upstream made no release so far.
   (let ((version "0")
-        (revision "1")
+        (revision "2")
         (commit "703e0d448c7ee24e25b513a3c65980c80e166805"))
     (package
       (name "emacs-libyaml")
@@ -22557,7 +22557,7 @@  utilities.")
                              (guix build gnu-build-system))
          #:phases
          (modify-phases %standard-phases
-           (add-before 'add-source-to-load-path 'substitute-libyaml-core-path
+           (add-after 'unpack 'substitute-libyaml-core-path
              (lambda* (#:key outputs #:allow-other-keys)
                (chmod "libyaml.el" #o644)
                (substitute* "libyaml.el"