diff mbox series

[bug#48482] gnu: Add ruby-taskjuggler.

Message ID 20210517163452.1859895-1-erikl@posteo.net
State New
Headers show
Series [bug#48482] gnu: Add ruby-taskjuggler. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Erik Lovlie May 17, 2021, 4:34 p.m. UTC
*  gnu/packages/ruby.scm (ruby-taskjuggler): New variable.
---

Fixed the commit message since this adds a package, not updating an
existing one.

 gnu/packages/ruby.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Jelle Licht May 29, 2023, 11:21 a.m. UTC | #1
Erik Lovlie <erikl@posteo.net> writes:

> * gnu/packages/ruby.scm (ruby-term-ansicolor): Update to 1.7.1.
[snip]

Superseded by 0fa988c089c4b1a835ef572cf953314b7c5af052 ...

Erik Lovlie <erikl@posteo.net> writes:

> *  gnu/packages/ruby.scm (ruby-taskjuggler): New variable.
[snip]

... and superseded by 234b340ae2ccdb147536b0bd941310724690eff4, so
closing this.
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e2f53bbdca..edc7f470ed 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6155,6 +6155,32 @@  of terminal output.")
     ;; There is no mention of the "or later" clause.
     (license license:gpl2)))
 
+(define-public ruby-taskjuggler
+  (package
+    (name "ruby-taskjuggler")
+    (version "3.7.1")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "taskjuggler" version))
+              (sha256
+               (base32
+                "1jrsajzhzpnfa8hj6lbf7adn8hls56dz3yw1gvzgz9y4zkka3k9v"))))
+    (build-system ruby-build-system)
+    (arguments
+     '(#:tests? #f))
+    (native-inputs
+     `(("ruby-rake" ,ruby-rake)))
+    (propagated-inputs
+     `(("ruby-mail" ,ruby-mail)
+       ("ruby-term-ansicolor" ,ruby-term-ansicolor)))
+    (synopsis "Project management software")
+    (description
+     "This package provides a project management tool with an optimizing
+scheduler that computes your project time lines and resource assignments based
+on the project outline and the constraints that you have provided.")
+    (home-page "https://taskjuggler.org/")
+    (license license:gpl2)))
+
 (define-public ruby-terraform
   (package
   (name "ruby-terraform")