diff mbox series

[bug#48459,1/3] gnu: tracker: Add missing dependencies.

Message ID 20210516050759.7239-1-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#48459,1/3] gnu: tracker: Add missing dependencies. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan May 16, 2021, 5:07 a.m. UTC
* gnu/packages/gnome.scm (tracker)[native-inputs]: Add python-wrapper.
[inputs]: Add bash-completion, network-manager and libstemmer.
[propagated-inputs]: Add glib.
---
 gnu/packages/gnome.scm | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)

Comments

Christopher Baines May 16, 2021, 7:36 a.m. UTC | #1
Raghav Gururajan via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/gnome.scm (tracker)[native-inputs]: Add python-wrapper.
> [inputs]: Add bash-completion, network-manager and libstemmer.
> [propagated-inputs]: Add glib.

Missing in my mind implies something was broken because of the missing
dependencies, and if that's the case, it would be good to note what
adding these missing dependencies fixes.

If these are just additional dependencies, it would also be good to note
what the addition of these dependencies enables.

> ---
>  gnu/packages/gnome.scm | 13 ++++++++++---
>  1 file changed, 10 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index be458c07bb..882b643067 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -133,6 +133,7 @@
>    #:use-module (gnu packages inkscape)
>    #:use-module (gnu packages iso-codes)
>    #:use-module (gnu packages kerberos)
> +  #:use-module (gnu packages language)
>    #:use-module (gnu packages libcanberra)
>    #:use-module (gnu packages libffi)
>    #:use-module (gnu packages libunistring)
> @@ -8753,14 +8754,20 @@ easy, safe, and automatic.")
>         ("python-pygobject" ,python-pygobject)
>         ("intltool" ,intltool)
>         ("pkg-config" ,pkg-config)
> +       ("python" ,python-wrapper)       ; she-bangs

shebang is one (very odd word):
 https://en.wikipedia.org/wiki/Shebang_(Unix)

That doesn't help me to understand what this (native?) input is being
added for though?

>         ("vala" ,vala)))
>      (inputs
> -     `(("dbus" ,dbus)
> +     `(("bash-completion" ,bash-completion) ; bash-completions

I'm not sure what the comment adds here?

> +       ("dbus" ,dbus)
>         ("sqlite" ,sqlite)
>         ("libxml2" ,libxml2)
> -       ("icu4c" ,icu4c)                 ; libunistring gets miner-miner-fs test to fail.
> +       ("icu4c" ,icu4c) ; libunistring gets miner-miner-fs test to fail.
>         ("json-glib" ,json-glib)
> -       ("libsoup" ,libsoup)))
> +       ("libnm" ,network-manager)       ; network status detection

This comment is useful.

> +       ("libsoup" ,libsoup)
> +       ("stemmer" ,libstemmer)))        ; stemming

I don't think this comment adds anything.

> +    (propagated-inputs
> +     `(("glib" ,glib)))                 ; referenced in .pc files

This one does though.

>      (synopsis "Metadata database, indexer and search tool")
>      (home-page "https://wiki.gnome.org/Projects/Tracker")
>      (description
Raghav Gururajan May 18, 2021, 3:14 a.m. UTC | #2
Hi Christopher,

> Missing in my mind implies something was broken because of the missing
> dependencies, and if that's the case, it would be good to note what
> adding these missing dependencies fixes.
> 
> If these are just additional dependencies, it would also be good to note
> what the addition of these dependencies enables.
> 
> shebang is one (very odd word):
>   https://en.wikipedia.org/wiki/Shebang_(Unix)
> 
> That doesn't help me to understand what this (native?) input is being
> added for though?
> 
> I'm not sure what the comment adds here?
> 
> I don't think this comment adds anything.
I revised the patch in v2.

Thanks!

Regards,
RG.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index be458c07bb..882b643067 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -133,6 +133,7 @@ 
   #:use-module (gnu packages inkscape)
   #:use-module (gnu packages iso-codes)
   #:use-module (gnu packages kerberos)
+  #:use-module (gnu packages language)
   #:use-module (gnu packages libcanberra)
   #:use-module (gnu packages libffi)
   #:use-module (gnu packages libunistring)
@@ -8753,14 +8754,20 @@  easy, safe, and automatic.")
        ("python-pygobject" ,python-pygobject)
        ("intltool" ,intltool)
        ("pkg-config" ,pkg-config)
+       ("python" ,python-wrapper)       ; she-bangs
        ("vala" ,vala)))
     (inputs
-     `(("dbus" ,dbus)
+     `(("bash-completion" ,bash-completion) ; bash-completions
+       ("dbus" ,dbus)
        ("sqlite" ,sqlite)
        ("libxml2" ,libxml2)
-       ("icu4c" ,icu4c)                 ; libunistring gets miner-miner-fs test to fail.
+       ("icu4c" ,icu4c) ; libunistring gets miner-miner-fs test to fail.
        ("json-glib" ,json-glib)
-       ("libsoup" ,libsoup)))
+       ("libnm" ,network-manager)       ; network status detection
+       ("libsoup" ,libsoup)
+       ("stemmer" ,libstemmer)))        ; stemming
+    (propagated-inputs
+     `(("glib" ,glib)))                 ; referenced in .pc files
     (synopsis "Metadata database, indexer and search tool")
     (home-page "https://wiki.gnome.org/Projects/Tracker")
     (description