diff mbox series

[bug#48440] gnu: guix: Update to 97d615b.

Message ID 20210515132819.20282-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#48440] gnu: guix: Update to 97d615b. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Christopher Baines May 15, 2021, 1:28 p.m. UTC
* gnu/packages/package-management.scm (guix): Update to 97d615b.
---
 gnu/packages/package-management.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Ludovic Courtès May 19, 2021, 8:51 p.m. UTC | #1
Hi,

Christopher Baines <mail@cbaines.net> skribis:

> * gnu/packages/package-management.scm (guix): Update to 97d615b.

In general LGTM if you’ve checked that it builds fine :-) and that
‘./pre-inst-env guix build -S guix --check’ passes (to avoid mistakes
such as wrong hash).

Out of curiosity, what was the motivation?

Thanks,
Ludo’.
Christopher Baines May 19, 2021, 11:04 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Hi,
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/package-management.scm (guix): Update to 97d615b.
>
> In general LGTM if you’ve checked that it builds fine :-) and that
> ‘./pre-inst-env guix build -S guix --check’ passes (to avoid mistakes
> such as wrong hash).
>
> Out of curiosity, what was the motivation?

I want the guix package to include the inferior package replacement
change [1], so that I can start using it in the Guix Data Service.

1: https://git.savannah.gnu.org/cgit/guix.git/commit/?id=97d615b1761c2054561057f6b56e2a0caed13aa4

I filed the patch because I couldn't get it to build locally, and I was
wondering if it was something specific to my machine. I think this was a
bad theory though, I'm guessing something has broken with the challenge
test so that it just hangs.
Christopher Baines May 22, 2021, 8:33 a.m. UTC | #3
Christopher Baines <mail@cbaines.net> writes:

> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Hi,
>>
>> Christopher Baines <mail@cbaines.net> skribis:
>>
>>> * gnu/packages/package-management.scm (guix): Update to 97d615b.
>>
>> In general LGTM if you’ve checked that it builds fine :-) and that
>> ‘./pre-inst-env guix build -S guix --check’ passes (to avoid mistakes
>> such as wrong hash).
>>
>> Out of curiosity, what was the motivation?
>
> I want the guix package to include the inferior package replacement
> change [1], so that I can start using it in the Guix Data Service.
>
> 1: https://git.savannah.gnu.org/cgit/guix.git/commit/?id=97d615b1761c2054561057f6b56e2a0caed13aa4
>
> I filed the patch because I couldn't get it to build locally, and I was
> wondering if it was something specific to my machine. I think this was a
> bad theory though, I'm guessing something has broken with the challenge
> test so that it just hangs.

I'm guessing this broken test was fixed just after I sent this email (in
[2]), so I've gone ahead and updated the Guix package now [3].

2: https://git.savannah.gnu.org/cgit/guix.git/commit/?id=0471024acce5f760ac147326c06343c9c68ad3d1
3: https://git.savannah.gnu.org/cgit/guix.git/commit/?id=fbabf0bec61c88755d6dd238717a356ca3a20b80
diff mbox series

Patch

diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index c72c2211b3..db8f87765b 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -132,8 +132,8 @@ 
   ;; Note: the 'update-guix-package.scm' script expects this definition to
   ;; start precisely like this.
   (let ((version "1.3.0")
-        (commit "771b866c55e5f992df60f6c32f5fdd78b64e17f6")
-        (revision 1))
+        (commit "97d615b1761c2054561057f6b56e2a0caed13aa4")
+        (revision 2))
     (package
       (name "guix")
 
@@ -149,7 +149,7 @@ 
                       (commit commit)))
                 (sha256
                  (base32
-                  "0w8w05w6v3lc6478vfw67jzn0hbd9nsncpx9i9ch1lck53r8vs44"))
+                  "1v8k7i897xc8kiyyxk5bc4rs37askq3ccdsmva0sjm7px6a2lzmz"))
                 (file-name (string-append "guix-" version "-checkout"))))
       (build-system gnu-build-system)
       (arguments