diff mbox series

[bug#48418] gnu: sameboy: Update to 0.14.3

Message ID 20210514140514.7311-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#48418] gnu: sameboy: Update to 0.14.3 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber May 14, 2021, 2:05 p.m. UTC
* gnu/packages/emulators.scm (sameboy): Update to 0.14.3.
[native-inputs]: Remove gcc-9.
[arguments]: Use cc-for-target instead of hard-coding gcc.
---
 gnu/packages/emulators.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

Comments

Roel Janssen May 21, 2021, 11:11 a.m. UTC | #1
Hi Felix,

On Fri, 2021-05-14 at 14:05 +0000, Felix Gruber wrote:
> * gnu/packages/emulators.scm (sameboy): Update to 0.14.3.
> [native-inputs]: Remove gcc-9.
> [arguments]: Use cc-for-target instead of hard-coding gcc.
> ---
>  gnu/packages/emulators.scm | 9 +++++----
>  1 file changed, 5 insertions(+), 4 deletions(-)
> 
> diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
> index 4367c23a6b..30cd2daf55 100644
> --- a/gnu/packages/emulators.scm
> +++ b/gnu/packages/emulators.scm
> @@ -14,6 +14,7 @@
>  ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
>  ;;; Copyright © 2020 Christopher Howard
> <christopher@librehacker.com>
>  ;;; Copyright © 2021 Felipe Balbi <balbi@kernel.org>
> +;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -637,7 +638,7 @@ and Game Boy Color games.")
>  (define-public sameboy
>    (package
>      (name "sameboy")
> -    (version "0.13.6")
> +    (version "0.14.3")
>      (source
>       (origin
>         (method git-fetch)
> @@ -646,17 +647,17 @@ and Game Boy Color games.")
>               (commit (string-append "v" version))))
>         (file-name (git-file-name name version))
>         (sha256
> -        (base32
> "04w8lybi7ssnax37ka4qw7pmcm7cgnmk90p9m73zbyp5chgpqqzc"))))
> +        (base32
> "1dipidx12ai62hnzf0pvnsk1cgjcmw1h5x2r7ilxq0k0pkia5b7a"))))
>      (build-system gnu-build-system)
>      (native-inputs
>       `(("rgbds" ,rgbds)
> -       ("gcc" ,gcc-9)
>         ("pkg-config" ,pkg-config)))
>      (inputs
>       `(("sdl2" ,sdl2)))
>      (arguments
>       `(#:tests? #f                      ; There are no tests
> -       #:make-flags `("CC=gcc" "NATIVE_CC=gcc" "CONF=release"
> +       #:make-flags `(,(string-append "CC=" ,(cc-for-target))
> +                      "NATIVE_CC=gcc" "CONF=release"
>                        ,(string-append "DATA_DIR="
>                                        (assoc-ref %outputs "out")
>                                        "/share/sameboy/"))

LGTM and pushed in 4bf2637c4947ad874821c58ca0eb2583753f5631.

Thank you!

Kind regards,
Roel Janssen
diff mbox series

Patch

diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 4367c23a6b..30cd2daf55 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -14,6 +14,7 @@ 
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;; Copyright © 2020 Christopher Howard <christopher@librehacker.com>
 ;;; Copyright © 2021 Felipe Balbi <balbi@kernel.org>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -637,7 +638,7 @@  and Game Boy Color games.")
 (define-public sameboy
   (package
     (name "sameboy")
-    (version "0.13.6")
+    (version "0.14.3")
     (source
      (origin
        (method git-fetch)
@@ -646,17 +647,17 @@  and Game Boy Color games.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "04w8lybi7ssnax37ka4qw7pmcm7cgnmk90p9m73zbyp5chgpqqzc"))))
+        (base32 "1dipidx12ai62hnzf0pvnsk1cgjcmw1h5x2r7ilxq0k0pkia5b7a"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("rgbds" ,rgbds)
-       ("gcc" ,gcc-9)
        ("pkg-config" ,pkg-config)))
     (inputs
      `(("sdl2" ,sdl2)))
     (arguments
      `(#:tests? #f                      ; There are no tests
-       #:make-flags `("CC=gcc" "NATIVE_CC=gcc" "CONF=release"
+       #:make-flags `(,(string-append "CC=" ,(cc-for-target))
+                      "NATIVE_CC=gcc" "CONF=release"
                       ,(string-append "DATA_DIR="
                                       (assoc-ref %outputs "out")
                                       "/share/sameboy/"))