diff mbox series

[bug#48403] gnu: warzone2100: Update to 4.0.1.

Message ID 20210513183155.13108-1-kkebreau@posteo.net
State Accepted
Headers show
Series [bug#48403] gnu: warzone2100: Update to 4.0.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Kei Kebreau May 13, 2021, 6:31 p.m. UTC
* gnu/packages/games.scm (warzone2100): Update to 4.0.1.
[arguments]: Disable vulkan backend with "-DWZ_ENABLE_BACKEND_VULKAN=off"
configure flag.
[inputs]: Add sqlite.
---
 gnu/packages/games.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Kei Kebreau May 13, 2021, 7:27 p.m. UTC | #1
I've submitted this patch because I'm unable to test the Vulkan
rendering backend on my hardware.  If someone wants to remove the
disabling configure flag and add the appropriate inputs, that'd be
great.  In either case, I'll push this patch within the next week.
Kei Kebreau May 26, 2021, 8:20 p.m. UTC | #2
Pushed to master as commit 2a8417d3b2.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 731c0cbc4a..f2289097bf 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5135,7 +5135,7 @@  in-window at 640x480 resolution or fullscreen.")
 (define-public warzone2100
   (package
     (name "warzone2100")
-    (version "3.4.1")
+    (version "4.0.1")
     (source
      (origin
        (method url-fetch)
@@ -5143,7 +5143,7 @@  in-window at 640x480 resolution or fullscreen.")
                            version
                            "/warzone2100_src.tar.xz"))
        (sha256
-        (base32 "0savalmw1kp1sf8vg5aqrl5hc77p4jacxy5y9qj8k2hi2vqdfb7a"))
+        (base32 "1f8a4kflslsjl8jrryhwg034h1yc9y3y1zmllgww3fqkz3aj4xik"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -5157,6 +5157,7 @@  in-window at 640x480 resolution or fullscreen.")
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags '("-DWZ_DISTRIBUTOR=Guix"
+                           "-DWZ_ENABLE_BACKEND_VULKAN=off"
                            "-DENABLE_DISCORD=off")
        #:tests? #f ; TODO: Tests seem to be broken, configure.ac is missing.
        #:phases
@@ -5202,6 +5203,7 @@  in-window at 640x480 resolution or fullscreen.")
               ("qtscript" ,qtscript)
               ("openssl" ,openssl)
               ("sdl2" ,sdl2)
+              ("sqlite" ,sqlite)
               ("utfcpp" ,utfcpp)))
     (home-page "https://wz2100.net")
     (synopsis "3D Real-time strategy and real-time tactics game")