diff mbox series

[bug#48325,v3,3/5] gnu: openlibm: Update to 0.7.4.

Message ID 20210513141105.10274-3-zimon.toutoune@gmail.com
State Accepted
Headers show
Series DRAFT: Update julia to 1.6.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier May 13, 2021, 2:11 p.m. UTC
From: Jean-Baptiste Volatier <jbv@pm.me>

* gnu/packages/maths.scm (openlibm): Update to 0.7.4.
---
 gnu/packages/maths.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

M May 14, 2021, 6:15 p.m. UTC | #1
zimoun schreef op do 13-05-2021 om 16:11 [+0200]:
> +       (list (string-append "prefix=" (assoc-ref %outputs "out")) "CC=gcc")

This most likely should use ,(string-append "CC=" (cc-for-target)) instead
of "CC=gcc", such that the cross-compiler is used when cross-compiling.
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9f7bdb9bb1..7be5d418e7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3959,7 +3959,7 @@  access to BLIS implementations via traditional BLAS routine calls.")
 (define-public openlibm
   (package
     (name "openlibm")
-    (version "0.6.0")
+    (version "0.7.4")
     (source
      (origin
        (method git-fetch)
@@ -3968,11 +3968,11 @@  access to BLIS implementations via traditional BLAS routine calls.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "08wfchmmr5200fvmn1kwq9byc1fhsq46hn0y5k8scdl74771c7gh"))))
+        (base32 "1azms0lpxb7vxb3bln5lyz0wpwx6jnzbffkclclpq2v5aiw8d14i"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags
-       (list (string-append "prefix=" (assoc-ref %outputs "out")))
+       (list (string-append "prefix=" (assoc-ref %outputs "out")) "CC=gcc")
        #:phases
        ;; no configure script
        (modify-phases %standard-phases (delete 'configure))