diff mbox series

[bug#48325,v3,2/5] gnu: Add pcre2-10.36.

Message ID 20210513141105.10274-2-zimon.toutoune@gmail.com
State Accepted
Headers show
Series DRAFT: Update julia to 1.6.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier May 13, 2021, 2:11 p.m. UTC
From: Jean-Baptiste Volatier <jbv@pm.me>

* gnu/packages/pcre.scm (pcre2-10.36): New variable.

Co-Authored-By: zimoun <zimoun.toutoune@gmail.com>.
---
 gnu/packages/pcre.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index ab48168567..8a1bd487fe 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -125,3 +126,16 @@  own native API, as well as a set of wrapper functions that correspond to the
 POSIX regular expression API.")
    (license license:bsd-3)
    (home-page "https://www.pcre.org/")))
+
+(define-public pcre2-10.36
+  (package
+    (inherit pcre2)
+    (name "pcre2")
+    (version "10.36")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/pcre/pcre2/"
+                                  version "/pcre2-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "0p3699msps07p40g9426lvxa3b41rg7k2fn7qxl2jm0kh4kkkvx9"))))))