diff mbox series

[bug#48396,3/4] gnu: node-lts: Add phase 'delete-cluster-tests.

Message ID 20210513130622.4288-3-mjbecze@riseup.net
State New
Headers show
Series Add nodejs 16.1.0 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Martin Becze May 13, 2021, 1:06 p.m. UTC
This adds a phases 'delete-cluster-tests which will be replaced by future
versions of node.

* gnu/packages/node.scm (node-lts): Add phase 'delete-cluster-tests.
---
 gnu/packages/node.scm | 15 ++++++++-------
 1 file changed, 8 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 17f435ca39..d7b46190e4 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -666,12 +666,6 @@  source files.")
                  (("'/usr/bin/env'")
                   (string-append "'" (which "env") "'")))
 
-               ;; FIXME: These tests fail in the build container, but they don't
-               ;; seem to be indicative of real problems in practice.
-               (for-each delete-file
-                         '("test/parallel/test-cluster-master-error.js"
-                           "test/parallel/test-cluster-master-kill.js"))
-
                ;; These require a DNS resolver.
                (for-each delete-file
                          '("test/parallel/test-dns.js"
@@ -713,7 +707,14 @@  source files.")
                             "deps/llhttp/src/http.c")
                  (copy-file (string-append llhttp "/include/llhttp.h")
                             "deps/llhttp/include/llhttp.h"))
-               #t))))))
+               #t))
+           (add-after 'patch-files 'delete-cluster-tests
+             (lambda _
+               ;; FIXME: These tests fail in the build container, but they don't
+               ;; seem to be indicative of real problems in practice.
+               (for-each delete-file
+                         '("test/parallel/test-cluster-master-error.js"
+                           "test/parallel/test-cluster-master-kill.js"))))))))
     (inputs
      `(("c-ares" ,c-ares/fixed)
        ("icu4c" ,icu4c-68)