diff mbox series

[bug#48384] gnu: Add emacs-tshell.

Message ID 20210512210507.230812-1-stefan@xsteve.at
State Accepted
Headers show
Series [bug#48384] gnu: Add emacs-tshell. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör May 12, 2021, 9:05 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-tshell): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Nicolas Goaziou May 14, 2021, 10:07 p.m. UTC | #1
Hello,

Stefan Reichör <stefan@xsteve.at> writes:

> * gnu/packages/emacs-xyz.scm (emacs-tshell): New variable.

I applied it with the changes explained below. Thank you!

> +(define-public emacs-tshell
> +  (let ((commit "47ef3a6c537b06eb422d9a124e1c44062223e323")
> +        (revision "0"))

I added a comment explaining why we are not using a tagged release.

> +    (package
> +      (name "emacs-tshell")
> +      (version (git-version "0.1" revision commit))

I changed "0.1" into "0.1.0" because that is what the Version keywords
says.

> +      (synopsis "A buffer-oriented Emacs shell.")

Synopsis must not start with an article and end with a period. You may
want to run "guix lint" to catch these.

> +      (description
> +       "This shell allows to run one line commands by hitting RET.  It supports
> +shell and emacs lisp commands.")

I slightly reworded the description.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ff90c6bd3a..193cdcad6e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27204,6 +27204,31 @@  easily.  Four pre-set options are: @samp{shell}, @samp{terminal},
 you use some other configuration.")
       (license license:gpl3+))))
 
+(define-public emacs-tshell
+  (let ((commit "47ef3a6c537b06eb422d9a124e1c44062223e323")
+        (revision "0"))
+    (package
+      (name "emacs-tshell")
+      (version (git-version "0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/TatriX/tshell")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0yv38bqdp6b614lbj4v408vv5mlic3vs1v7266xrfxm1cm903apj"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-transient" ,emacs-transient)))
+      (home-page "https://github.com/TatriX/tshell")
+      (synopsis "A buffer-oriented Emacs shell.")
+      (description
+       "This shell allows to run one line commands by hitting RET.  It supports
+shell and emacs lisp commands.")
+      (license license:gpl3+))))
+
 (define-public emacs-extmap
   (package
     (name "emacs-extmap")