diff mbox series

[bug#48345] gnu: Add emacs-packed.

Message ID 20210511112344.15843-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#48345] gnu: Add emacs-packed. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler May 11, 2021, 11:23 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-packed): New variable.
---
 gnu/packages/emacs-xyz.scm | 31 ++++++++++++++++++++++++++++++-
 1 file changed, 30 insertions(+), 1 deletion(-)

Comments

Nicolas Goaziou May 21, 2021, 3:54 p.m. UTC | #1
Hello,

Leo Prikler <leo.prikler@student.tugraz.at> writes:

> +       (uri (string-append "https://stable.melpa.org/packages/packed-"
> +                           version ".el"))

Is it really stable? Wouldn't it be simpler to use git-fetch from
upstream directly?

> +Where a package manager might depend on metadata, Packed instead
> +uses some heuristics to get the same information — that is slower

Nitpick: I think usual typography is like

  same information---that is slower...

Otherwise LGTM.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 869f8c3c7b..22d22df0b8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -55,7 +55,7 @@ 
 ;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
 ;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
 ;;; Copyright © 2019 Stephen Webber <montokapro@gmail.com>
-;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
+;;; Copyright © 2019, 2021 Leo Prikler <leo.prikler@student.tugraz.at>
 ;;; Copyright © 2019 David Wilson <david@daviwil.com>
 ;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
 ;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
@@ -19877,6 +19877,35 @@  e.g. the package dependencies it requires.  See function
 file.")
       (license license:gpl3+))))
 
+(define-public emacs-packed
+  (package
+    (name "emacs-packed")
+    (version "3.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://stable.melpa.org/packages/packed-"
+                           version ".el"))
+       (sha256
+        (base32
+         "0rd6svls19qskn03pa54rx5qfvxzgs639cdycix4bkf5ayzypj5h"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/emacscollective/packed")
+    (synopsis "Package manager agnostic Emacs Lisp package utilities")
+    (description
+     "Packed provides some package manager agnostic utilities to work
+with Emacs Lisp packages.  As far as Packed is concerned packages
+are collections of Emacs Lisp libraries that are stored in a
+dedicated directory such as a Git repository.  And libraries are
+Emacs Lisp files that provide the correct feature (matching the
+filename).
+
+Where a package manager might depend on metadata, Packed instead
+uses some heuristics to get the same information — that is slower
+and might also fail at times but makes it unnecessary to maintain
+package recipes.")
+    (license license:gpl3+)))
+
 (define-public emacs-picpocket
   (let ((version "40")
         (commit "6fd88b8711c4370662c0f9c462170187d092a046"))