diff mbox series

[bug#48296,1/1] gnu: Add python-sqlalchemy-stubs.

Message ID 20210508204124.38500-2-me@bonfacemunyoki.com
State Accepted
Headers show
Series gnu: Add python-sqlalchemy-stubs | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Munyoki Kilyungi May 8, 2021, 8:41 p.m. UTC
* gnu/packages/databases.scm (python-sqlalchemy-stubs): New variable.
---
 gnu/packages/databases.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Arun Isaac May 9, 2021, 10:48 a.m. UTC | #1
Hi Bonface,

> +    (license license:expat)))

Save minor cosmetic changes, this packages LGTM. But, there is some
confusion with the license. The LICENSE file is Apache 2.0, but setup.py
says "MIT License". Could you clarify this with upstream?

Thanks!
Munyoki Kilyungi May 10, 2021, 9:38 a.m. UTC | #2
Hi Arun!

Arun Isaac <arunisaac@systemreboot.net> anaandika:

> Hi Bonface,
>
>> +    (license license:expat)))
>
> Save minor cosmetic changes, this packages LGTM. But, there is some
> confusion with the license. The LICENSE file is Apache 2.0, but setup.py
> says "MIT License". Could you clarify this with upstream?
>
Thanks for catching that. I've just created an
issue here: https://github.com/dropbox/sqlalchemy-stubs/issues/216
Arun Isaac May 12, 2021, 10:46 a.m. UTC | #3
> Thanks for catching that. I've just created an
> issue here: https://github.com/dropbox/sqlalchemy-stubs/issues/216

Thanks for reporting the bug. I changed the license in your package
description, made a few cosmetic changes and pushed to master.

Thanks!
Munyoki Kilyungi May 12, 2021, 1:47 p.m. UTC | #4
Arun Isaac <arunisaac@systemreboot.net> anaandika:

>> Thanks for catching that. I've just created an
>> issue here: https://github.com/dropbox/sqlalchemy-stubs/issues/216
>
> Thanks for reporting the bug. I changed the license in your package
> description, made a few cosmetic changes and pushed to master.
>
> Thanks!
>
Thanks for taking the time to work on this. FWIW,
upstream updated the setup.py too.
Arun Isaac May 15, 2021, 7:48 a.m. UTC | #5
> Thanks for taking the time to work on this. FWIW,
> upstream updated the setup.py too.

That's great, thank you! Next time we update this package, we will have
the fixed setup.py too.
Munyoki Kilyungi May 17, 2021, 7:02 a.m. UTC | #6
Arun Isaac <arunisaac@systemreboot.net> anaandika:

>> Thanks for taking the time to work on this. FWIW,
>> upstream updated the setup.py too.
>
> That's great, thank you! Next time we update this package, we will have
> the fixed setup.py too.
>

Yup. This makes sense.
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 2777293200..54cf394d17 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -50,6 +50,7 @@ 
 ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
 ;;; Copyright © 2021 Pjotr Prins <pjotr.guix@thebird.nl>
+;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -114,6 +115,7 @@ 
   #:use-module (gnu packages popt)
   #:use-module (gnu packages protobuf)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-check)
   #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-science)
   #:use-module (gnu packages python-web)
@@ -2926,6 +2928,30 @@  simple and Pythonic domain language.")
 (define-public python2-sqlalchemy
   (package-with-python2 python-sqlalchemy))
 
+(define-public python-sqlalchemy-stubs
+  (package
+    (name "python-sqlalchemy-stubs")
+    (version "0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "sqlalchemy-stubs" version))
+       (sha256
+        (base32
+         "1bppjmv7v7m0q8gwg791pgxbx4ay7mna0zq204pn9vw28kfxcrf6"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-mypy" ,python-mypy)
+       ("python-typing-extensions"
+        ,python-typing-extensions)))
+    (home-page
+     "https://github.com/dropbox/sqlalchemy-stubs")
+    (synopsis "SQLAlchemy stubs and mypy plugin")
+    (description "This package contains type stubs and a mypy plugin to
+provide more precise static types and type inference for SQLAlchemy
+framework.")
+    (license license:expat)))
+
 (define-public python-sqlalchemy-utils
   (package
     (name "python-sqlalchemy-utils")