diff mbox series

[bug#48286] gnu: Add emacs-cwl-mode.

Message ID 20210508132910.3930-1-arunisaac@systemreboot.net
State Accepted
Headers show
Series [bug#48286] gnu: Add emacs-cwl-mode. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Arun Isaac May 8, 2021, 1:29 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-cwl-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 ++++++++++++++++++++++++-
 1 file changed, 24 insertions(+), 1 deletion(-)

Comments

Xinglu Chen May 8, 2021, 2:16 p.m. UTC | #1
On Sat, May 08 2021, Arun Isaac wrote:

> * gnu/packages/emacs-xyz.scm (emacs-cwl-mode): New variable.
>
> [...]
>
> +    (synopsis "Emacs mode for Common Workflow Language (CWL) files")
> +    (description "This packages provides a major mode for editing Common
> +Workflow Language (CWL) files.")

Nitpick: use @acronym{} maybe?

Builds fine on my end. :)
Arun Isaac May 8, 2021, 5:51 p.m. UTC | #2
> Nitpick: use @acronym{} maybe?

That's a good suggestion. I added @acronym, updated the package and
pushed to master. Thanks for the review! :-)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 869f8c3c7b..7ba9ef4148 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16,7 +16,7 @@ 
 ;;; Copyright © 2016, 2019 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
 ;;; Copyright © 2017, 2018, 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017, 2018, 2019, 2020, 2021 Clément Lassieur <clement@lassieur.org>
@@ -27881,3 +27881,26 @@  files, providing syntax highlighting and indentation rules.")
 quasi-prefix map, with many useful bindings.  These bindings are
 shorter than usual, using mostly unprefixed keys.")
     (license license:gpl3+)))
+
+(define-public emacs-cwl-mode
+  (package
+    (name "emacs-cwl-mode")
+    (version "0.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tom-tan/cwl-mode")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "04xqnm27y1h9z8csjpys4v3lkgn5kvpw9n4q94pbrvjgmz0qfp58"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-yaml-mode" ,emacs-yaml-mode)))
+    (home-page "https://github.com/tom-tan/cwl-mode")
+    (synopsis "Emacs mode for Common Workflow Language (CWL) files")
+    (description "This packages provides a major mode for editing Common
+Workflow Language (CWL) files.")
+    (license license:gpl3+)))